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 1. Welcome to Tgi3D® SU Plugin Help
Tgi3D® SU (Tgi3D® SketchUp Plugin) is a plug-in for SketchUp that contains tools that supports: 

1) Creating realistic 3D models from photographs by extending the matched-photo interface of 
SketchUp.

2) Creating  3D  models  with  free-form  surfaces  by  supplying  various  utilities  for  creating 
smooth meshes. 

Initial  sections  of  the Tgi3D® SU Help  document  provides  step-by-step instructions  on how to 
perform tasks  specific  to  Tgi3D® SU plug-in.  Sections  following  Section   14. contains  all  the 
reference material pertaining to Tgi3D® SU Plugin tools and commands.

This document assumes a basic knowledge of 3D modeling and familiarity with using SketchUp.  

Note: The Tgi3D® CT (Tgi3D® SU PhotoScan Calibration Tool) is a photogrammetry software that 
facilitates an interface to mark matching points on multiple images for  camera calibration and 
taking measurements between the marked points. Tgi3D CT is available only in the Tgi3D® SU 
PhotoScan package.

5



 2. Tgi3D® SU Overview
Tgi3D® SU is a collection of interactive 3D drawing tools that extend SketchUp in two fundamental 
ways:

1) Tgi3D®  SU support  3D modeling  of  real-world  objects  captured in  the  form of  multiple 
images taken from different locations and angles. The plugin depends on the Photo Match 
interface of SketchUp for drawing models from photographs; but It provides a much more 
effective interface due to the patented view-lock drawing technique.

2) Tgi3D®  SU contains various tools for creating and editing smooth meshes controlled by 
Bézier curves to enable creating 3D models with amorphous shapes.

 2.1.  View-locking
View-lock is a motion constraint that  enables the user manipulate a 3D drawing primitive without 
changing its appearance on a selected input image (or on a desired camera view). Under the view-
lock constraint you can move (using the Tgi3D Move tool) the primitive to align its appearance on 
another view, without changing its appearance on the locked view. In a typical project, you need to 
go through a number of lock and align operations to draw the primitive correctly in 3D.

Figure 1 is a step by step demonstration of the lock and align operation:

a) Figure 1-a shows a line segment overlayed on the edge of the coffee table on a photo-
match page. After the line is drawn correctly on this page, it is locked with “Lock selection” 
command from the context menu.

b) Figure 1-b shows the same line on a different page. It does not coincide with the edge of 
the  table.  When you  move the end  of  the  line  using  the  Tgi3D Move tool,  a  red line 
representing the lock or equivalently the motion constraint appears. As long as the vertex 
moves  on  the  red-line  (this  constraint  is  enforced  by  the  Tgi3D  Move  Tool  only),  its 
appearance won't change on the first page. It becomes possible to align the line segment 
with the edge of the table without affecting its appearance on the first page. 

c) Figure 1-c  shows  the  same  line  segment  after  the  alignment  operation.  Now the  line 
coincides with the edge of the table on the second page as well. 

d) Figure 1-d shows the same line on a third page. It matches the edge of the table again. 
Actually we expect a match on an arbitrary page showing the edge of the table, which 
means that the line is reconstructed perfectly in 3D.

Theoretically having the line segment matching the image on two views guarantees its 
reconstruction; but in practice calibration errors and degenerate camera configurations such 
as narrow angle camera pairs require exercising the lock and align operations on other 
cameras as well.



(a) (b)

(c) (d)

Figure 1: The steps of lock and align operation

 2.2.  Tools and Commands
Apart from the lock and align mechanism, Tgi3D® SU comes with various utilities and tools for 
drawing complex objects including the ones with amorphous shapes.  Some of these tools are 
limited to the photo-match pages as they operate on the images together with the model. The other 
s including the lock and align mechanism can be used on the fly from an arbitrary view as they only 
operate  on  the  model.  Without  a  photo-match  page,  the  view-lock  uses  viewing  camera  of 
SketchUp, representing a particular view of the object just like its 2D drawing.
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Tgi3D  Toolbar,  shown  in  Figure  2,  contains  seven  tools,  namely  Tgi3D  Select,  Tgi3D  Move,  
Construction  Point,  Cross  Section,  Set  World  Coordinates,  Warper  and  Image-Based  Surface  
Modeler (PhotoScan only) tools. The last icon in the toolbar pops up the Tgi3D Settings dialog box. 
Among these tools, Tgi3D Select tool makes Tgi3D specific selection of SketchUp entities easier, 
Tgi3D Move tool moves the entities under the Tgi3D specific constraints and creates and modifies 
Bézier curves, Construction Point tool creates construction points and Cross Section tool enables 
you to efficiently edit cross sections of extrusions. Set World Coordinates  allows you to transform 
the whole model to align it with the world coordinate system of SketchUp, which determines the 
ground plane and the default light source. Warper tool creates a Tgi3D specific bounding box, 
which is used for warping (i.e changing the shape of) the selected surface. Channel Extrude tool 
extrudes  selected edges  along  a  preselected  connected  path  of  edges.  Finally,  Image-Based 
Surface Modeler (PhotoScan only)  pops up another toolbar that  contains commands for  fitting 
surfaces to images. They are also located under Tools menu of SketchUp.

Figure 2: The Tgi3D Toolbar

There are also various commands distributed to File, Edit, Tools, Help menu and context menu of 
SketchUp mainly for mesh creation, warping and smoothing operations to shape surfaces, vertex 
operations to lock or fix vertices inside the  Tgi3D Move tool,  and  creating and modifying Bézier 
curves.



 3. Setting up the Matched Photo Pages
In order to be able to draw objects using photographs, first the images should be loaded to the 
matched-photo pages of SketchUp and the corresponding perspective camera parameters should 
be set correctly. There are two ways of calibrating the cameras of matched photo pages.

1. SketchUp itself provides a novel interface for the calibration of cameras (see the SketchUp 
documentation on matching photos). If high reconstruction accuracy or the lens distortion is 
not an issue, and the images have appropriate content (e.g. buildings) this interface can be 
easily  used.  The  image matching  utility  in  Tgi3D®  SU does  not  work  with  this  type  of 
calibration.

2. Calibrate  the  cameras  using  Tgi3D® CT  (Tgi3D® SU  PhotoScan  Calibration  Tool)  that 
comes with the Tgi3D® SU PhotoScan package. Tgi3D® CT calibrates the cameras using 
manually marked point matches and takes the lens distortion into account. It can provide 
highly accurate camera calibration results.  The tool exports lens distortion wise corrected 
images, and the camera parameters with or without cloud of points used in calibration to a 
SketchUp file.  Just  use the  exported file,  which  contains  the  calibrated matched-photo 
pages, as a start-up for your modeling project.  We recommend using Tgi3D® CT for best 
results.

Note: Tgi3D CT versions prior to 1.16 do not export the calibration results  as a SketchUp 
file; instead a folder containing the calibration data  (model.t3f) and the lens distortion wise 
corrected  images  is  generated.  This  folder  should  be  imported  to  SketchUp using  the 
“Plugins > Tgi3D > Utils >  Import Tgi3D Calibration...“ command in  Tgi3D® SU Plugin.
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 4.  World Coordinates and Drawing Axes
SketchUp has a fixed coordinate system with a fixed ground plane and a single light source, which 
is the Sun. The location of the Sun is determined with respect to ground plane using the time and 
date in shadow settings. Besides this fixed world coordinate axes it is possible to define drawing 
axes to change the red, green and blue axis used in inference of SketchUp while drawing.

If  you  use   Tgi3D® CT export  output  as  a  starting  point  you  may want  to  change  the  world 
coordinate system so that the cameras and the reconstructed objects lie over the ground plane 
and cast shadows correctly. You can use Set World Coordinates tool located on the Tgi3D Toolbar 
(see Section  2.2.) for this purpose. The tool works similar to the Axes tool of SkecthUp.

Note: We  strongly  recommend  to  setup  the  world  coordinates  in  Tgi3D® CT  before  export; 
because the axes information provided by the user is utilized to calibrate the cameras to satisfy the 
desired world coordinate system accurately.

When you change the drawing axes by some means in SkecthUp, the change is not reflected 
automatically in Photo-match pages. When you switch to a photomatch page you loose the current 
drawing frame as the drawing axes in that page is activated. If you want to change the drawing  
frame axes in the pages as well,  you can use the “Edit-->Update Tgi3D page axes” command, 
which sets the drawing axes of all Tgi3D photo-match pages to the current drawing axes.



 5. View Locking
View locking (patent pending) is a central feature of Tgi3D® SU. View locking a vertex constrains 
the 3D position of that vertex in such a way that its appearance from the locked view is invariant 
(i.e. constant). That is, further edits to the vertex in other views do not affect its position in the 
locked view. You will notice that the movement of the view locked vertex is restricted on a line in 
other views (e.g. the red line in Figure 1-b). This line is the line that connects the original position of 
the vertex to the view's optic center. In its simplest usage, a vertex is locked from one view and 
then the vertex is moved to its correct 3D position in other views.

 5.1.  View locking vertices of a line
To view lock the vertices of a line:

1. If you are not already in Tgi3D Move mode, pick the Tgi3D Move tool

2. Right click to select the line 

3. Select “Lock selection” command in the context (or pop-up) menu.

 5.2.  View locking a Bézier Curve
To view lock a Bézier curve

1. If you are not already in Tgi3D Move mode, pick the Tgi3D Move tool

2. Right click on the curve

3. Select  “Lock curve” command in the context menu.

 5.3.  View locking a single vertex or construction point
To view lock a single vertex or a construction point:

1. If you are not already in Tgi3D Move mode, pick the Tgi3D Move tool

2. Place the cursor on the vertex 

3. Right click on the vertex 

4. Select “Lock single vertex” command in the context menu.

 5.4.  View locking vertices of a selection
To view lock the vertices of a selection:

1. If you are not already in Tgi3D Move mode, pick the Tgi3D Move tool

2. Right click on the selection

3. Select “Lock selection” command in the context menu.

Under  Tgi3D Move tool,  the vertex in focus appears highlighted in different colors and shapes 
depending on lock and fix status as shown in Table 1

Colors:

Blue: no lock

Red: locked from the current point of view

Orange: locked from some other point of view
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Shapes:

Triangle:  vertex is  fixed (i.e.  vertex is  immovable)  for  smoothing and image matching 
operations.

Rectangle: vertex is not fixed (i.e. vertex is movable) for smoothing and image matching 
operations.

No Lock Locked in 
current View

Locked in 
another view

No fix

Fixed

Table 1: Lock and fix status under Tgi3D Move tool

Note: You can perform view lock to arbitrary cameras (photo associated or not, perspective or not).



 6. Editing lines, Bézier curves and Construction Points
Lines are the basic geometric primitives of SketchUp that are enough to capture a wide range of 
shapes; on the other hand many objects in the photographs have smooth curvy boundaries and 
management of polyline representations of these boundaries gets very unpractical as the number 
of segments increases. Therefore Tgi3D® SU includes support for the manipulation of 3D Bézier 
curves, which are well behaved curves with the ability to capture a wide range of shapes with a few 
parameters. Tgi3D® SU does not include a tool to directly draw Bézier curves, instead the lines 
drawn by SketchUp line tool are converted to third order Bézier curves using Tgi3D Move tool or 
the context menu.

Construction points form another type of entity that can be processed by Tgi3D® SU. In SketchUp 
construction points are  not part of the model but are used as guides while drawing. It is possible to 
create, lock, and move construction points using Tgi3D® SU plugin. 

 6.1.  Converting a line to a Bézier curve
You can convert a line to a Bézier curve in two ways:

Either

1. Select the line

2. Click the right mouse button while the cursor is on the line

3. Select the Convert to Bézier Curve item in the context menu.

or

1. Make sure the Tgi3D Move tool is picked

2. (Windows) Press and hold the 'Ctrl' key on the keyboard

        (Mac) Press and hold the 'option' (or 'alt') key on the keyboard

3. Press and hold the left mouse button on any point on the line and drag the mouse (just 
clicking without dragging is also enough for the conversion).

Figure 3 shows the initial and final states of the line for the second method.

 6.2.  Stretching and stressing a curve
To stretch or stress a curve:

1. If you are not already using the Tgi3D Move tool, click the Tgi3D Move tool icon from the 
Tgi3D toolbar.

2. Grab and pull from any point on the curve. 

You will observe that as the grab point gets closer to one end of the curve that side of the curve is 
affected more by the motion.

 6.3.  Exploding a Bézier  curve
Ordinary SketchUp explode operation destroys the curves, but Tgi3D® SU will still recognize them 
as Bézier curves. If you want to completely explode a Bézier curve, you need to use the Explode 
Bézier Curve menu item in the context menu. To explode a single curve

1. Click the right mouse button while the cursor is on the line

2. Select the Explode Bézier Curve item in the context menu.
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To explode multiple curves

1. Select the curves you want to explode. Exact selection is not needed, just make sure the 
selection includes all the Bézier curves to be exploded.

2. Click the right mouse button on the selection

3. Select the Explode Bézier Curve item in the context menu.

(a) (b)

Figure 3: Converting a line to a Bézier curve

 6.4.  Splitting a line or a curve
To split a line or a curve:

1. If you are not already using the Tgi3D Move tool, click the Tgi3D Move tool icon from the 
Tgi3D toolbar.

2. Position the cursor at the point you want to split the line or curve.

3. Double click the left mouse button.

Note: Curves lying on or at the border of meshes attached to faces can not be split. Instead, new 
samples are added to the curve at the point specified by the mouse  

 6.5.  Changing sampling rate on the curve
To change the sampling rate on a curve or multiple curves:

1. Select the curve(s).  Exact selection is not needed, just make sure the selection includes all 
the Bézier curves to be resampled.

2. Right click on the selection

3. Select Resample Bézier Curve... item in the context menu. 

4. Enter the desired number of vertices on the curve(s) in the Bézier Curve Info dialog box

5. Press “Enter” key or click “OK” button on the dialog box.

Hint:  For reasonable model size and manipulation ease, use the fewest samples that meet your 
accuracy requirement.

Note: If the curve have attached faces, then resampling operation will not work. However you can 
explicitly insert a sample at a desired location by double clicking at that location on the desired 
edge. 



 6.6.  Drawing a 3D line matching to the photographs
To draw a 3D line matching to the photographs:

1. Draw the line on a photograph to match the desired feature or edge of the object in the 
picture

2. Select the line

3. View lock the line in the current photo

4. Select Tgi3D Move tool (unless already selected)

5. Move the ends of the line to match the same feature in other photo(s).

 6.7.  Matching lines to image features automatically (PhotoScan Only)
With Tgi3D® SU you can adjust the position of lines to match the desired feature in a photograph. 
To use automatic adjustment:

1. Position the line close to the desired feature

2. Select the line (or move the cursor over the line if inside the Tgi3D Move tool)

3. Make sure Tgi3D Move (or Tgi3D Select) tool is on

4. Press and release key “K”, until you want to end the matching process.

Note: For  the  automatic  vertex  match  operation  to  work  properly,  there  needs  to  be  enough 
contrast  in  the  photograph.  Sometimes there  may be fake edges due to shadows etc.  in  the 
photograph which makes it impossible to perform automatic matching.

Caution: This feature is only available in Tgi3D® SU PhotoScan product and works with SketchUp 
files exported by Tgi3D® CT (Tgi3D® SU PhotoScan Calibration Tool).

 6.8.  Drawing a 3D curve matching to the photographs 
To draw a 3D curve:

1. Select Tgi3D Move tool (unless already selected)

2. Draw the curve on a photograph to match the desired feature or edge of the object in the 
picture by stretching and stressing the curve

3. View lock the curve in the current photo

4. Modify the curve to match the same feature in other photo(s).

 6.9.  Matching curves to image features automatically (PhotoScan Only)
With Tgi3D®  SU you can adjust the curves to match the desired feature in a photograph. To use 
automatic adjustment:

1. Position and adjust the shape of the curve close to the desired feature

2. Select the curve (or move the cursor over the curve if inside the Tgi3D Move tool)

3. Make sure Tgi3D Move (or Tgi3D Select) tool is on

4. Press and release keys “J” and “K” interchangeably, until you want to end the matching 
process.

Note: For  the  automatic  vertex  match  operation  to  work  properly,  there  needs  to  be  enough 
contrast  in  the  photograph.  Sometimes there  may be fake edges due to shadows etc.  in  the 
photograph which makes it impossible to perform automatic matching.

Caution: This feature is only available in Tgi3D® SU PhotoScan product and works with SketchUp 
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files exported by Tgi3D® CT (Tgi3D® SU PhotoScan Calibration Tool).

 6.10.  Drawing a 3D construction point matching to the photographs
To draw a 3D construction point

1. Choose Tgi3D Construction Point tool

2. Left click on the desired position. The depth will be assigned by SketchUp using coincident 
geometry (i.e. if there is a plane/face the point will be placed on the face, if it is close to an 
edge the point will be on that edge etc). 

3. View lock the construction point

4. Edit the position of the construction point using the  Tgi3D Move tool from other viewing-
positions/photos  if  desired.  If  there  are  no  locks,  the  Tgi3D  Move tool  will  restrict 
construction point to a plane which is perpendicular to the present camera's viewing axis.

 6.11.  Moving lines and curves restricted to a face-plane
To move lines and curves restricted to a face plane, use Tgi3D Move tool simultaneously pressing 
and holding the 'Shift' key. The face closest to the cursor location determines the restriction plane.

For example, to convert a line in a plane to a curve in the same plane:

1.  (Windows) Press and hold 'Ctrl' and 'Shift' keys

 (Mac) Press and hold 'option' (or 'alt') and 'Shift' keys

2. Drag from any point on the line using the Tgi3D Move tool.

Note: If you have a view lock on a surface, the vertex that is restricted to the plane cannot be  
moved (intersection of a plane and a line is a point).

 6.12.  Snapping a vertex to another vertex
Similar to the “Move Tool” of SketchUp, it is possible to snap and merge the end-points of curves 
and line segments to other vertices under the Tgi3D Move Tool by simultaneously pressing and 
holding the 'Shift' key. If there is a face close to the cursor location the motion is restricted on that 
face as explained in Section  6.11.; otherwise a close enough vertex is chosen. Snap occurs when 
you release the mouse button after a green circle with an 'Endpoint' highlight is displayed. The 
point being moved is merged with the existing vertex.

 6.13.  Re-sampling Paths
Any smoothly connected set of edges, Bezier curves or SketchUp curves is called a path. The 
smoothness is determined by the “Curve crease angle” option in the Tgi3D settings (see Section 
 24.1.). Sometimes it may be desirable to get a uniformly sampled path that is made up of same 
length segments. “Resample path” command in the context menu is used for this purpose:

1. Select the curves edges etc to be re-sampled. Re-sampling  will be applied to the paths 
made up of edges without any faces.

2. Right click on the selection select  Resample path item from the context menu.

3. Enter the desired segment length in the dialog box that will pop-up and press enter.

 6.14.  Temporarily hiding the drawing
           Action: Press and hold the 'W' key

While using the Tgi3D Move tool you can temporarily remove the drawing so that fine details are 
easier to observe in the underlying photo by clicking the 'W' key on the keyboard.



 7. Creating and Editing Smooth Surfaces
The lines and curves capture the edges of the objects in the scene, smooth meshes are needed to 
represent the surfaces bounded by these edges. There also exist various objects corresponding to 
closed surfaces without any edge boundaries. Tgi3D® SU contains a number of utilities to create 
and modify meshes representing the surfaces of the objects.

In general, Tgi3D® SU surfaces are made up of smooth surface patches bounded by curves as 
shown by the blue dotted lines in Figure 4. The nature of the edges on the curves determine the 
continuity of the surface normals. The patches form smooth transitions across smooth, soft,  or 
hidden  curves.  The  surface  can  be  reshaped  by  first  modifying  the  control  curves  and  then 
applying different types of smoothing operators. Depending on the Tgi3D settings the curves on or 
at the border are kept fixed in smoothing, therefore determine the shape of the surface. 

             

Figure 4: Smooth surfaces and control curves

An alternative method without the curves is employing fixed vertices as control points. The surface 
is forced to pass through the fixed vertices in smoothing  In mesh creation, the construction points 
serve the same purpose as there are no vertices to be fixed.

 7.1. Creating a surface
To create a surface:

1. Select the boundaries of the surface you want to create. Use the Tgi3D Select tool for an 
easier and faster selection (i.e. Ctrl + Left click on Windows, or alt/option + Left click on 
Mac) of the boundary.

2. Include construction points, if any, indicating 3D locations from which the surface will pass.
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3. Right click on the selection and select Create Mesh item from the context menu. Note that 
you can also access the context menu from the Edit menu of SketchUp.

4. Depending on the selected boundary “Create Mesh Options” dialog may show up to allow 
you choose the type of surface to be created (see Section  7.10.). Just select the surface 
type and click OK to continue.

If the boundary has an existing surface and the boundary edges on that surface are smooth, or 
hidden or softened then the new mesh will form a smooth transition from the existing surface. If the 
edges are visible edges representing hard boundaries,  the smooth transition constraint  will  be 
dropped. 

The resolution of the mesh is kept proportional to the number of line segments at the boundary. 

 7.2.  Smoothing a surface
To smooth a surface

1. Select the surface to be smoothed.  Use the  Tgi3D Select tool  for  an easier  and faster 
selection of connected surface regions.

2. Each time you press the 'U' key (smooth operation) on the keyboard the smoothness of the 
surface will be improved 

Smoothing operation moves the vertices of the mesh such that the discontinuities or sharp features 
around the soft/hidden/smoothed edges are minimized. Smoothness optimization process does not 
try to smooth hard edges (i.e. the edges that are not soft, smooth or hidden). If there are locks on  
the vertices, those vertices are restricted to their locks. If a vertex is not locked it moves along the 
vertex normal.  Also,  fixed vertices are not  affected by this operation (i.e.  their  location is  kept 
constant). Vertices of edges with neighboring unselected faces are treated as fixed. Note if you 
want to reach to a steady state of the smooth surface quickly, you may choose to press 'Shift+U' 
instead.

Caution: If the selected surface has no constraints (no unselected neighboring faces or no fixed 
vertices) then the optimally smooth shape is a plane.

 7.3.  Redistributing the Vertices of a Mesh
Stretching  and  stressing  the  control  curves  or  moving  the  vertices  affects  the  distribution  of 
triangular faces over the surface. It is best to have a close to uniform tiling over the surface.  If you  
wish to redistribute the  triangles, just make sure that the vertices in the selection do not have view 
locks and press 'Y' key (Redistribute and Smooth operation) after selection. This will in general 
generate a smooth surface with a close to uniform tiling. In this mode, the surface is assumed to be 
made up of either a stiff or elastic material depending on the option chosen in Tgi3D Settings. You 
can issue the command repeatedly by hitting  the 'Y' key or press 'Shift+Y' instead to reach to the 
steady state of  the  redistribution   quickly.  The redistribute and smooth operation has a strong 
smoothing capability; it can iron out deep wrinkles and irregularities on the surface.

Note: In general, one needs to issue a sequence of  “Redistribute and Smooth ('Y')” and pure 
“Smoothing ('U')” commands for shaping a surface.

 7.4.  Changing Surface Shape using Control Curves
If you want to modify the shape of your surface with control curves

1. Use the Tgi3D move tool to edit the curves on or at the boundary of the surface.

2. Select the whole surface.  Use the Tgi3D Select tool for an easier and faster selection of 
connected surface regions.

3. Use smoothing commands ('U' or 'Y') keys to get a smooth surface.

A sample surface before and after editing is shown in Figure 5-a and b respectively. The controls 
curves can be viewed using the Edit → Select All Curves command. The behavior of smoothing 



depends on the   “Assume Bézier curves as fixed” option in Tgi3D settings. If this option is turned 
off, you need to fix the vertices of your curves explicitly using the “Fix selection” command in the 
context menu; otherwise the smoothing operation will smooth out the soft curves as if they don't 
exist.  

(a) (b)

Figure 5: Editing a smooth surface 

 7.5.  Increasing the resolution of a surface
The number of triangles in the mesh can be increased using the Up-sample operation. 

1. Select the surface where you want to increase the resolution. Use the Tgi3D Select tool for 
an easier and faster selection of connected surface regions.

2. Right click on the selection and select Upsample from the context menu. Note that you can 
also access the context menu from the Edit menu of SketchUp.

3. Set the upsample options in the dialog box (see Section ) that will show up  and click OK.

Up-sampling basically increases the resolution of the surface by splitting each face in the selection 
and interpolating the location of new vertices to get a smoother looking surface. 

An important feature of the up-sampling operation is the preservation of surface discontinuities 
marked by hard edges. The hard edges are treated as smooth curves whenever possible during 
the up-sampling process. The curve crease angle parameter in Tgi3D settings is used to determine 
the curve the hard edge resides on, if it is not already specified as a Bézier curve.

 7.6.  Decreasing the resolution of a surface
It  is  often desirable to minimize the number of  faces,  vertices and edges on a mesh to save 
memory and increase processing speed. Tgi3D® SU Plugin comes with a down-sampling utility  to 
decrease the resolution of the mesh surfaces down to a desired quality level. To down-sample

1. Select the surface where you want to decrease the resolution.
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2. Right click on the selection and select Downsample from the context menu. Note that you 
can also access the context menu from the Edit menu of SketchUp.

3. Set the downsample options in the dialog box (see Section  7.11.) that will show up  and 
click OK.

 7.7.  Image-Based Surface Modeling (PhotoScan Only)
Given  the  photographs  and  the  parameters  of  the  corresponding  cameras,  it  is  possible  to 
reconstruct an object using image matching techniques. The basic rule is that the projections of the 
surface points should match on the corresponding photographs. Image-Based Surface Modeler in 
Tgi3D® SU PhotoScan  activates a set of commands for the color matching based reconstruction 
rule to find the real shape of the surface.  To shape surfaces using image content:

1. Create a surface as described in Section 7.1. and select it.

2. Lock vertices of the surface on a photograph where the surface has good visibility (i.e. all 
selected faces are visible directly).

3. Switch to another photograph with a good view of the surface

4. Activate the Image-Based Surface Modeler tool that will pop-up a new tool bar containing 
various commands

5. Issue the image matching commands that cause to selected surface to evolve to match the 
current and locked photograph.

See Section  9. for a detailed guide to using the image-based surface modeler.

Caution: This  feature  is  available  in  Tgi3D® SU PhotoScan  product  and  only  works  with  the 
SketchUp files exported by Tgi3D® CT (Tgi3D® SU PhotoScan Calibration Tool). 

 7.8.  Smart surface matching to photographs (i.e. image matching) 
(PhotoScan Only)

Apart  from the Image-Based surface modeler  described in  Section   7.7. there is  also a more 
primitive  image  matching  utility  that  works  with  surfaces  close  to  their  real  shape  in  the 
photographs.  To create a surface in 3D to match the photographs:

1. Create a surface as described in Section 7.1.

2. Lock vertices of the surface on a photograph where the surface has good visibility (i.e. all 
selected faces are visible directly).

3. Select the surface.

4. Switch to another photograph with a good view of the surface

5. Use the Tgi3D Move tool to deform the surface, especially its boundary so that it appears 
close to its view on the photograph.

6. Make sure Tgi3D Select (or Tgi3D Move) tool is on

7. Each time you press 'N' key on the keyboard the surface will evolve to match both the the 
current and locked photograph

Note: If the surface on the current photograph does not improve (i.e. initial surface was not close 
enough  to  the  final  surface),  then  you  can  reinitialize  the  surface with  a  better  match to  the 
photographs (current and locked photographs) by pressing 'Shift+N' on the keyboard.

Note: This is a time consuming operation; too big an area or too many vertices will take a long time 
to optimize. Soft edges, will resist buckling in this operation so that the final surface is smooth. If  
you want sharp corners you must leave those edges as hard edges (i.e. no hiding, smoothing, or 
softening).

Caution: This feature is available in Tgi3D® SU PhotoScan product and only works with SketchUp 
files exported by Tgi3D® CT (Tgi3D® SU PhotoScan Calibration Tool). 



 7.9.  Entering Angular Constraints
Angular constraint is the desired angle between two face normals connected to a hard edge (no 
hiding, smoothing, or softening). These constraints are used (and satisfied) in surface smoothing, 
redistribution and  especially  in  Plane  Optimization operations  (accessed  via  'D'  and  'Shift+D' 
shortcuts). Plane optimization operation is used especially when you want to create objects whose 
faces are all planes, e.g. cubes, cuboids, hexahedrons, tetrahedrons etc. In plane optimization, it is 
advised that you fix a vertex and the other vertices are aligned relative to this vertex.

Move the cursor over an edge that can accept angular constraint (only hard edges with two faces 
can have angular constraints). To enter an angular constraint:

1. Right click on the highlighted edge to access the context menu

2. Choose change Angular Constraint... item in the context menu

3. Enter the desired angle in degrees in the dialog box that shows up and click OK.

Entering '-1' degrees as angular constraint removes existing constraint on the edge.

 7.10.  Create Mesh Options Dialog Box
If the boundary of the mesh to be created consists of three or four different Bézier curves (see 
Section  6.), all having compatible number of samples, the “Create Mesh Options” dialog box will 
show up to allow the user to select the type of surface to be created as shown in Figure 6. You can 
either  choose to create a Bézier surface or just a smooth surface, which is the default type of 
surface when the Bézier surface creation conditions are not met.

 
Figure 6: Create mesh options
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 7.11.  Downsample Options Dialog Box 
The downsample options determine the visual quality of the output of mesh reduction process. 
High quality means an output that looks just like the original mesh; however depending on the 
geometry of the object the reduction in memory requirement of the mesh may not be as low as 
desired. In that case the quality should be decreased.

The desired output quality can be set directly using the basic downsample options as shown in 
Figure  7. The desired  quality level can be set as a number between 0 and 100 using the slider 
control. 

 
Figure 7: Basic downsample options

In  advanced  downsample  options,  the  mesh  reduction  is  controlled  by  setting  the  maximum 
allowable surface rotation and displacement as shown in Figure 8. In mesh reduction some of the 
vertices and the corresponding faces and edges on the mesh are removed.  Allowable surface 
normal rotation limits  the  rotation  in  face  normals  after  removal.  Similarly,  allowable   surface 
displacement limits the translation in faces.

Figure 8: Advanced downsample options



 7.12.Upsample Options Dialog Box
Downsample options determine the smoothness of the resulting mesh after upsampling as shown 
in Figure  9. The upsampling creates a smoother mesh if  extra smoothing is  desired;  however 
depending on the size of the mesh it may take a very long time to smooth the surface.

Figure 9: Upsample options
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 8. Warping Objects
Menu: Tools > Warper

Toolbar icon:  

Warper is a Tgi3D tool that help modelers deform the selected surfaces including the ones inside 
the selected groups and components. Using the warper tool consists of three basic steps:

1. Create a warper, which is basically a bounding box of your selection placed in a new group 
as shown in Figure 10-(a). The warper group has a default orientation (bounding box in the 
world coordinates). But you can rotate scale translate and shear (guess using warper or 
scale tools) it as an ordinary component instance, it will be as if the warper was created in 
the orientation after the edit.

2. Edit bounding box inside the group as shown in Figure 10-(b) to modify the bounding box. 
All  your  edits  including  scale,  rotate,  translate  etc  done  inside  the  component  will  be 
reflected to the output. If you use Tgi3D tools in modification a preview of the deformation 
result is displayed.

3. Finally  issue  the  Warp command  to  apply  the  transformation  of  the  warper  on  the 
corresponding object as shown in Figure 10-(c) 

 8.1.  Creating the Warper
To create a warper

1. Select the surfaces you want to reshape and either 

                 a) click on the Warper icon in the Tgi3D toolbar, or

b) choose the “Create warper” command in the context menu that pops up after right 
clicking on the selection.

2. Set options for the warper to be created in the dialog box that pops up (see Section  8.4.), 
then a bounding box will be created around your selection as a new group.

3. Optionally you may want to  change the alignment of the bounding box with respect to the 
selection by rotating, translating or scaling the group.

 8.2.  Editing the Warper
In order to edit the warper

1. Double click or use the “Edit Group” command in the context menu to edit the bounding box 
itself.

2. Edit the edges and vertices of the bounding box using any tool you want. If you use Tgi3D 
tools and if the  transform preview option was selected to be on in the  warper  creation 
process, you can preview the result of your transformation while editing.  Do not change 
the connectivity of the bounding box by deleting edges or creating extra connections 
between the edges or vertices.

3. Click outside the group or choose the “Close Group” command in the context menu when 
you are finished with editing.



(a) (b)

(c)

Figure 10: Basic steps of using the warper

 8.3.  Transforming the object
1. To modify the shape of object(s) corresponding to the warper, select the group and either

a) click on the Warper icon in the Tgi3D toolbar, or

b) choose the Warp command in the context menu that pops up after right clicking on 
the selection.

2. If  you  want  to  modify  the  object(s)  further  just  go  on  with  editing  the  bounding  box. 
Otherwise you can simply delete it, because the bounding box is valid only for the current 
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editing session of SketchUp. Even if you save it, it won't be active next time you open the 
file.

 8.4.  Warper Options
Warper Options dialog box shows up when the “Create warper” command is issued. It is possible 
to set the type of transformation to be applied on the SketchUp groups and components in the 
selection and turn on/off the preview mode as shown in Figure 11.

Figure 11: The warper options dialog box

The dialog box contains the following options:

• Child  component  transformation  type:  These  options  determine  the  type  of 
transformation  to  be  applied  on  the  selected  components  and  groups.  There  are  six 
different options:

a. Full: The given transformation is applied to the whole hierarchy as if the whole selection 
were  flat.  In  the  process  it  may  have  to  uniquify  instances  with  more  than  one 
instances.  This  mode is  interesting  because it  leaves the instances intact,  enabling 
smooth edits on large designs despite sketchup performance issue. You can  can easily 
warp large designs where you can not  even hope to explode and flatten the whole 
thing. For the other options the hierarchy is preserved.

b. Nothing: The component (group) instances in the selection are ignored, they are left 
untouched.

c. Translation: The instances are translated only with an average amount (as determined 
from the transformation on the warper)

d. Rigid: Rotation and translation only (the amounts are approximated to be optimally 
matching the transformation)

e. Similarity: Rotation, Translation, and uniform scaling.

f. Affine: Rotation,  Translation,  arbitrary  scaling,  and  shear  (this  is  equivalent  to  the 
SketchUp component instance transformation matrix).

• Transform preview: When the transform preview is turned on and one of the Tgi3D tools 
are used for editing, the result of the transformation can be previewed instantly. You may 
want to turn preview off for very large meshes as it may slow down editing.



 9.  Image-Based Surface Modeling (PhotoScan Only) 
Menu: Tools > Image-Based Surface Modeler

Toolbar icon:  

Image based surface modeler is a Tgi3D tool that help modelers create free form surfaces that 
match  the  images  on  photomatch-pages.  The  basic  image  based  surface  modeling  process 
consists of the following steps:

1. Create a mesh on one of the photomatch pages facing the surface you want to draw at a 
right angle. Do not bother about the 3D shape of the mesh, just assume you are creating a 
2D mesh over the photograph on the page.

2. Lock the mesh on the current view using the Tgi3D “Lock selection” command.
3. Switch to another photograph facing the surface from a different angle.
4. Choose the Tgi3D image based surface modeler tool, which will pop-up a new toolbar.
5. Use the command buttons on the toolbar for shaping the surface.
6. Check the markers appearing on the mesh that you created. Pure green plus signs indicate 

successfully matched triangles on the mesh, while red minus signs indicate bad matches. 
The ones without any signs are neutral. You can also check the quality of the surface from 
other views. Do not expect to get a good match all over the surface.

7. Depending on your evaluation in Step 6, you can go to Step 5 to issue another match 
command or stop if you are satisfied with the result. If your previous command resulted in a 
very low quality surface you can issue an undo command and go to Step 5 to issue another 
one.

The  Image-Based Surface Modeler Toolbar contains the following commands:

Toolbar Icon Menu command

Tools → Initial Estimate

Tools → Single-Segment Surface

Tools → Multi-Segment Surface

Tools → Refine Estimate

Tools → Upsample Mesh

Tools → Flip if necessary

Tools → Image-Based Surface Modeler Help
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 9.1.  Initial Estimate
Initial estimate is used for reshaping surfaces that are far away from the target surface. You can 
determine such surfaces by checking the markers on it and its appearance on a view other than 
the locked one. 

If the surface

     a) have all negative (i.e. red) markers on it, or

     b) appears off the target surface on any of the available images, or

     c) is not connected to another surface that is already shaped correctly,

you may want to use initial estimate command

Initial estimate command corresponds to a long range search targeting multiple surfaces.

 9.2.  Single-Segment Surface
Single-segment surface is a smooth surface that you can unfurl using a single sheet of a soft 
material without any  tears; otherwise the surface is called a multi-segment       surface. Single-
segment surfaces do not contain any creases  or breaks. A ball or the torso of human body can be 
considered as a  single-segment surface,  while the whole surface of a cube is a  multi-segment 
surface due to vertical creases at the edges of the cube. The total visible surface of an object and 
another object partially occluding it should also be considered as a  multi-segment surface  due to 
the breaks, which are discontinuities in  space. It is impossible to unfurl two different objects with a 
single sheet.

Use the single-segment surface command for a surface

      a) that does not contain very sharp creases, an

      b) that does not contain breaks as in the case of multiple objects.

Single-segment  surface  command  corresponds  to  a  medium  range  search  targeting  a  single 
smooth surface.

 9.3.  Multi-Segment Surface
Single-segment surface is a smooth surface that you can unfurl using a single sheet of a soft 
material without any  tears; otherwise the surface is called a multi-segment       surface. Single-
segment surfaces do not contain any creases  or breaks. A ball or the torso of human body can be 
considered as a  single-segment surface,  while the whole surface of a cube is a  multi-segment 
surface due to vertical creases at the edges of the cube. The total visible surface of an object and 
another object partially occluding it should also be considered as a  multi-segment surface  due to 
the breaks, which are discontinuities in  space. It is impossible to unfurl two different objects with a 
single sheet.

Use the multi-segment surface command for a surface

      a) that contains very sharp creases, or

      b) that contains breaks as in the case of multiple objects.

Multi-segment surface command corresponds to a medium range search targeting multiple smooth 
surfaces.

 9.4.  Refine Estimate
Refine estimate command improves the  quality of matching regions on the mesh. It can be used 
to after  obtaining a fairly good estimate of the target surface. It  corresponds to a narrow range 
search to let the mesh adapt to the  fine details of the target surface.



 9.5.  Upsample Mesh
Upsampling increases the resolution of the mesh. It is best to start image-based modeling with low-
resolution meshes.  Once you get  a good estimate of  the  surface at  a low resolution use the 
upsample mesh  and  refine estimate command to obtain a more detailed mesh to represent the 
target surface.

 9.6.  Flip if necessary
This command changes the topology of the mesh to capture sharp discontinuities in the surface. 
The edges are  flipped as  in  the “Flip  Edge”  tool  of  the  Sandbox Plugin based on the image 
matching quality. The effect of flipping is demonstrated in Figure 12. The distortion indicated  by the 
circle in Figure 12-a is removed after executing the Flip if necessary command as shown in Figure 
12-b.

(a) (b)

Figure 12: The effect of flipping on the quality of the model

 9.7.  Image-Based Surface Modeler Help
This command pops up a window that displays detailed information about the image-based surface 
modeler.
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 10. Editing Extrusions
The Push/Pull tool in SketchUp help creating solid objects instantly from planar faces. Tgi3D® SU 
includes a “Cross Section” tool for scaling and translating the cross sections of these extrusions. It 
becomes possible to model a wide range of objects (e.g. wine glass, pipes, trees … etc.) using 
cross section editing. 

(a) (b)

(c) (d)

Figure 13: Cross section tool in action

The operation of Cross Section Tool is demonstrated in Figure 13. Inside this tool when you move 
the  cursor  on  a  cross  section  of  an  extrusion,  the  cross  section  that  will  be  affected  will  be 
highlighted  (see  Figure 13-a)  (it  is  strongly  advised  that  View  >  Hidden  Geometry option  of 
SketchUp is checked). If you perform a drag operation (hold the left mouse button and move the 
cursor) the cross section expands or contracts, following the cursor (see Figure 13-b). When the 
dragging  is  finished  the  extrusion  is  reshaped  to  fit  the  new cross  section  (see  Figure 13-c). 
Figure 13-d shows the result with the View > Hidden Geometry option of SketchUp is unchecked.



 10.1.  Types of Cross Section transformations
Depending on the key modifier there three types of transformations applied on the cross section:

1. No Modifier:  The cross section is expanded or shrinked. The expand and shrink method 
can be chosen from Tgi3D Settings between scale and offset (default is scale).

2. Shift Modifier: Translate the selected cross section longitudinally.

3. Ctrl Modifier: Translate the selected cross section transversely. (Windows)

alt/option Modifier: Translate the selected cross section transversely. (Mac)

 10.2. Creating a cross section
Action: Double click with left mouse button

When this tool is selected as you move the cursor on an edge, it  is highlighted in green (see 
Figure 14-a) if it is possible to create a cross section crossing that edge. Than you can create a 
new cross section crossing the highlighted edge at the cursor location by a left double-click (see 
Figure 14-b).

(a) (b)

Figure 14: Creating a new cross section

 10.3.  Confusions in cross section resolution
The Cross Section tool resolves the cross section automatically. A cross section should be a closed 
planar contour passing through the edge pointed by the cursor. When the tool can not resolve the 
cross  section  uniquely,  it  highlights  the  possibilities  in  red  as  shown  Figures 15-a  and  15-b. 
Depending on the mouse cursor location one them will be selected and displayed with a thicker 
highlight. For example in Figure 15-a the circular cross section is selected as the mouse cursor 
points to its face. In case of confusions, just hover the mouse over the sides of highlighted cross 
sections to select the correct one and go on with the operation as if  a single cross section is  
highlighted.

31



(a) (b)

Figure 15: Confusions in cross-section resolution



 11.  Creating and Mapping Textures
SketchUp has a number of utilities such as “Project photo”, “Position Texture Tool”, and “Make 
Unique Texture” commands to apply textures on surfaces; but they are not practical or satisfactory 
to be used on smooth organic shapes made up of large number of faces. Tgi3D® SU Plugin comes 
with a much more practical “Create Texture...” utility to apply texture over smooth surfaces.

Given a selection of faces, “Create Texture...” utility creates a texture map and a texture image. If 
there is already a texture applied on any part of the selection, it is preserved in the new texture 
image.  Preserving the existing texture helps avoid discontinuities in the texture. Once the texture 
image is created one can edit the image using the “Edit Texture Image” command in SketchUp.  

 11.1.  Applying texture on a selected region
In order to apply texture on a selected region

1. Select  the  surface  to  be  textured.  Use  the  Tgi3D Select tool  for  an  easier  and  faster 
selection of connected surface regions.

2. Right click on the selection.

3. Select “Create Texture...” command in the context menu.

4. Set the desired “Create Texture Options” in the dialog box (see Section  11.4. for details) 
that shows up and press OK.

The create  texture  command will  create  a  material  with  a  texture  image and  apply  it  on  the 
selection. You may assign a name to the material in the Create Texture Options dialog box (see 
Section   11.4. for details) to find and edit the material later in the “Material Browser” window of 
SketchUp.

The crucial parameter of texture creation is the texture mapping method. You may choose  the 
method by trial and error.  If none of the texture mapping methods produce satisfactory results, 
narrow down your selection and try again. There are currently three methods of texture mapping:  
Unwrap, Spherical and Planar.

1)  Unwrap method tries to map the geometry with no distortion. Unwrap method works 
best when you can flatten the selected surface without any tears. If it has to place tears,  
it does not quite know where best to place them. You can indeed select chunks of mesh 
and texture piece by piece.

2)  Spherical mapping on the other hand may introduce stretching distortions due to the 
non-linearity of the transformation.  Similar to the unwrapping method the only way to 
minimize he distortions is to manually tear the surface and texture it piece by piece.

3) Planar method maps the selected faces to the most common plane in the selection (i.e., 
the plane with the largest total area). This feature is especially useful for architectural 
applications. If the faces already have mapped textures (e.g. via “Project photo”), then 
this  feature  basically  provides  a  rectified  photograph  (or  orthophoto  feature)  without 
perspective distortion. 

    
We would like to point out here that in either spherical or unwrap mode, the selected part of the 
mesh can be already textured,  then the newly created texture will  seamlessly merge with the 
existing texture. This is especially useful when you have to texture the whole mesh in chunks. This 
way you can edit  your textures to be seamless between chunks. You can even repair  existing 
texture seams using this feature 
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 11.2.  Editing the created texture
In order to edit the texture that is created by the “Create Texture...” command

1. Go to the “Material Browser” of SketchUp. You can use the “Paint Bucket Tool” (Press B as 
a short cut) to easily access the  Material Browser. In order to view the textures available in 
the model, you need to

       (Windows) Click on the “Select” tab and select “In Model” item from the listbox menu.  

               (Mac) Click on the “Texture Palettes” icon (top rightmost icon) and select

                          “Colors In Model” item from the listbox menu.  

2. Find the material that is just created by the create texture command. Assigning a name to 
the material in the Create Texture Options dialog box (see Section  11.4. for details) may 
help you to find the material easily.

3. Use the “Edit Texture” command as shown in Figure 16 to load and edit the texture image 
in  your  image editor.  The default  image  editor  can  be  set  in  the  SketchUp's  “System 
Preferences” dialog (can be accessed via Window > Preferences menu item) as shown in 
Figure 17 (Note: we recommend you to use layer based image editors).

4. When you close the editor SketchUp automatically refreshes the material using the  edited 
texture image (Note: SketchUp's automatically refreshing of the texture may take a long 
time on Mac OS X systems).

Figure 16: Editing texture image in SketchUp



Figure 17: The SketchUp preferences window for setting the default image editor

 11.3.  Applying texture on the whole surface of an object
In order to apply texture to the whole surface an object you need to

1. Select a region to be textured on the object surface. If  the region has already textured 
neighbors, include those faces in your selection.

2. Create a texture using the procedure given in Section  11.1.

3. Edit the texture using the procedure given in Section  11.2. As the neighboring textures are 
preserved in the new texture it becomes possible to preserve continuity in editing.

4. Go to Step 1 if there is an untextured region on the object.

 11.4.  Create Texture Options Dialog Box
Create Texture Options dialog box shows up when the “Create Texture...” command is issued. It is 
possible to set the image attributes, texture mapping method, and the target of the texture in this 
dialog box as shown in Figure 18.

The dialog box contains the following options:

• Material Name: This field determines the name of the material that will be created. If it is 
left blank, a random material name is assigned.

• Image width: The width of the texture image in pixels

• Image height: The height of the texture image in pixels

• Apply to: The texture material is applied on the front, back or both sides of the selected 
surface depending on the value of this option.

• Mapping method: This options determines the texture coordinates of the surface elements 
in the image. Texture mapping requires mapping the selected surface to a 2D plane without 
any overlaps, which can be a very complex even an impossible process depending on the 
topology of the selected surface. There are two choices for the mapping:
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• Unwrap: The surface is unwrapped (or ironed out) to a plane. The surface can be 
torn if necessary to avoid faces having overlapping mapping regions on the texture 
image. Tearing the surface creates discontinuities, which may be undesirable. The 
surface should be a single connected region for the unwrapping method to work.

• Spherical:  The selection  is  first  mapped to  a  sphere.  It  is  guaranteed  to  be  a 
continuous  mapping  without  any  tearing  but  depending  on  the  coverage  of  the 
sphere the mapping can produce highly stretched texture maps.

• Planar: The selection is mapped to to the most common plane in the selection (i.e., 
the  plane  with  the  largest  total  area).  This  feature  is  especially  useful  for 
architectural applications.

The methods are not guaranteed to work on an arbitrary selection. If none of the methods 
produce satisfactory results you need to narrow down your selection and try again.

• Output format: This option determined the format of the texture image. You can choose 
JPEG image (jpg) or PNG image (png) as the output format. The PNG format is required  if 
you want to assign variable transparency over the texture image.

• Create UV Map: The texture mapping itself is saved as a separate material  if this options is 
set to “yes”. The mapping is represented with an image made up of the boundaries of faces 
in the selection. It can be used as a guiding layer in drawing your texture image. 

Note: Selecting “no” will not have any effect if there is no existing image texture on the 
selected faces.  In that  case,  the UV map will  be always drawn on the created texture 
image. 

                        Figure 18: The Create Texture Options dialog box.



 11.5.  Safeguarding texture maps
When applied to a textured surface, many tools of SketchUp such as the Move or Scale tools 
distort the texture map in an unpredictable way. It becomes difficult to edit already textured images 
under SketchUp. Therefore Tgi3D provides safeguard and restore utilities to preserve the texture 
maps. In order to safeguard texture maps:

1. Select the textured faces to be safeguarded. Use the Tgi3D Select tool for an easier and 
faster selection of connected surface regions.

2. Right click on the selection.

3. Select “Safeguard Texture map” command in the context menu.

In order to restore texture maps:

1. Right click on any part of the model to access the context menu.

2. Select “Restore texture map” command to restore all of the safeguarded texture maps.

When the safeguarded texture maps are restored the safeguarding is removed as 
well.
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 12.  Transporting Model to a New Calibration (PhotoScan Only) 
In general, camera calibration is an iterative process and the camera calibrations are improved 
either by adding more calibration points and/or adding new cameras. Suppose that you improved 
your  previous  camera  calibrations  using  Tgi3D CT and  export  the  new calibrations  to  a  new 
SketchUp (SKP) file. In order to transport your previous drawings to the new SketchUp file with the 
improved camera calibrations, please follow the following six steps.

1. Open both the old SKP file which contains your previous drawings and the new SKP file 
with the new camera calibrations in SketchUp.

2. In the old SKP file,  select the drawings you want to transport to the new SKP file and 
activate the “Group to transport” command via the context menu, “Other Tgi3D Utilities >  
Group to transport”  or  the  “Plugins”  menu,   “Plugins  >  Tgi3D > Transport  >  Group to  
transport”. This command will produce a selected group from the selected entities, which is 
ready for transportation.

3. In the old SKP file, copy the selected group, which is created in Step 2, via the “Edit” menu, 
“Edit > Copy”.

4. Switch to the new SKP file and paste the copied group in place, via the “Edit” menu, “Edit > 
Paste In Place”.

5. In the new SKP file, select the newly transported group and activate the “Ungroup from 
transport” command via the context menu, “Other Tgi3D Utilities > Ungroup from transport” 
or  the “Plugins”  menu,   “Plugins >  Tgi3D > Transport >  Ungroup from transport”.  This 
command will transform the selected group  to fit into the new calibration and explode the 
group making the entities available to the user.  You can now save the new SKP file to 
contain the previous drawings.

6. Close the old SKP file (preferably without saving).

At the end of this six-step process the previous drawings should have been transported to the new 
calibration successfully and are ready for further modifications.



 13.  Terrain Operations
 Tgi3D SU plugin includes a number of helper features that can be used in terrain-based designs.

 13.1.  Terrain Mapping
It is sometimes desirable to build complex models such as cities or parks over terrains; however 
building the model directly on the terrain can be very difficult due to its non-planar nature. Terrain 
mapping allows one to build the model over the ground plane then map it to the terrain.

In order to use the terrain mapping functionality first you need to mark the terrain to be used in 
mapping:

1. Select the mesh representing the terrain.

2. Right click on the selection.

3. Select “Set  Target Terrain” command in the context menu.

The target terrain will be hold fixed for the following mapping operations. To map your model to the 
target terrain;

After building your model over the ground plane

1. Select your model.

2. Right click on the selection.

3. Select “Map to terrain command” command in the context menu.

4. Set the options in the terrain mapping options dialog box shown below in Figure  19 and 
press the “OK” button.

Figure 19: Terrain mapping options dialog-box.

The  terrain Mapping Options dialog box contains  a “Child component transformation type” 
option  that  determines the  type  of  mapping  transformation to  be  applied  on  the  selected 
components and groups. There are four different options:

a. Full: The mapping is applied to the whole hierarchy as if the whole selection were flat. 
In  the  process  it  may  have  to  uniquify  group  or  components  with  more  than  one 
instance.  For the other options the hierarchy is preserved.

b. Translation: The instances are translated only with an average amount (as determined 
from mapping)

c. Rigid: Rotation and translation only (the amounts are approximated to be  optimally 
matching the mapping transformation)

d. Affine: Rotation,  Translation,  arbitrary  scaling,  and  shear  (this  is  equivalent  to  the 
SketchUp component instance transformation matrix).
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 13.2.  Channel Extrusion
Extrusion operation is a powerful tool for creating 3D objects There are various forms of extrusions 
available in SketchUp or in other SketchUp plugins. Channel extrusion refers to a special type of 
extrusion that can be used in terrain operations such as road or channel creation over the terrain. 
Channel extrusion extrudes a set of edges or curves over a preselected path of edges without 
changing their alignment with respect to ground plane (i.e red-green plane) of SketchUp. 

(a) (b)

Figure 20: Operation of channel extrusion tool

To use the channel extrusion tool

1. Select  the path along which the extrusion will  be performed. A singly connected set  of 
edges should be selected.

2. Click the “Channel Extrude” icon on the toolbar (see Section  2.2. and  20.)  The selected 
path will turn red when the tool is activated as shown in Figure 20-a.

3. Select the profile to be extruded by clicking on it. To make multiple selections, press the 
Shift  key before  selection  and do not  release it  until  all  the  edges to be extruded are 
selected.

4. The result of extruding the selected profile shown in Figure 20-a along the preselected path 
in red color is shown in Figure 20-b.



 14. Tgi3D Select Tool

Menu: Tools > Tgi3D Select

Toolbar icon: 

This tool provides additional selection capabilities for mesh based operations to SketchUp's own 
select tool.

 14.1. Selecting a face and its edges
Action: Click left mouse button

Position the cursor over the face to be selected and click the left mouse button.

 14.2. Selecting multiple faces
You can select multiple faces in two ways using Tgi3D Select tool:

1. Position the cursor over each face and click the left mouse button one by one

or,

2. Drag the mouse over multiple faces while holding down the left mouse button. 

 14.3. Tagging  faces
Tgi3D® SU Plugin allows the user assign tags to the faces. The faces with the same tag can be 
selected with a single double-click by the Tgi3D selection tool.

To assign tags to the faces:

1. Select the faces to be tagged

2. Right click on the selection

3. Choose “Tag faces” command in the context menu

To clear tags of  the faces:
1. Select the faces to be untagged

2. Right click on the selection

3. Choose “Untag faces” command in the context menu

 14.4. Bounded selection
Action:  Left mouse double click (on a face)

Double clicking the left mouse button on a face without a tag, starts selecting all the faces (and 
edges) physically connected to that face until a boundary (e.g. hard edge) is reached.

If the first face is tagged, all the neighboring faces with the same tag are selected.
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 14.5. Incremental Bounded selection
Action:  (Windows) Ctrl + Left mouse double click (on a face)

                       (Mac) alt/option + Left mouse double click (on a face)

The operation is similar to bounded selection  (see Section  14.4.). The difference is the behavior 
on an existing selection. The existing selection is not cleared. If the first face does not have a tag 
the new selection stops at a  previously selected face or edge or a boundary edge for faces. 

If the first face is tagged, all the neighboring faces with the same tag are selected.

 14.6.  Selecting the boundaries and curves on a surface
Action:   (Windows) Ctrl + Left mouse click (on an edge)

                        (Mac) alt/option + Left mouse click (on an edge) 

If you press and hold the 'Ctrl' key ('alt/option' key on Mac) and click the left mouse button 

1. On a boundary edge:  The selection expands until  a bifurcation (of boundary edges) is 
encountered.

2. On a hard edge inside surface: The selection expands until a boundary or a bifurcation 
(of hard edges) is encountered.

3. On a curve edge inside surface: The selection expands until the whole curve is selected. 
A curve edge will be highlighted in yellow color when the cursor is over it.

4. On a soft edge inside surface: The selection expands until a boundary, a hard edge or a 
bifurcation (when all crease angles are higher than 33° degrees) is encountered.

Note: A boundary edge is defined as edge with less than two faces.

 14.7. De-selecting faces and their edges
Action: Shift + Left mouse click (on a  face)

To deselect a face that has already been selected:

1. Position the cursor over a face that has already been selected

2. Press and hold the 'Shift' key and click the left mouse button

To deselect multiple faces:

1. Press and hold the 'Shift' key and the left mouse button while dragging the cursor over the 
faces to be deselected.

 14.8.  Bounded deselection
Action: Shift + Left mouse double click (on a  face)

Holding the 'Shift' key and double clicking the left mouse button on a selecting face without a tag, 
starts deselecting all the faces (and edges) physically connected to that face until a boundary (e.g. 
hard edge or a unselected face) is reached. 

If the first face is tagged, all the neighboring faces with the same tag are deselected.



 14.9. Deselecting the boundaries and curves on a surface
Action: (Windows) Ctrl + Shift + Left mouse click (or Shift + Left mouse click)

                      (Mac) alt/option + Shift + Left mouse click (or Shift + Left mouse click)

If you press and hold the 'Ctrl+Shift' key ('alt/option'+Shift key on Mac) and click the left mouse 
button  on  a  selected  edge  on  a  surface,  the  de-selection  expands  until  a  bifurcation  inside 
selection is encountered as explained in Section 14.6.

Deselection also works with a 'Shift + Left mouse click' combination if there is no selected face on 
that edge, otherwise selected face will be deselected.

Note:  A boundary edge is defined as edge with less than two faces.
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 15.  Tgi3D Move Tool

Menu: Tools > Tgi3D Move

Toolbar icon: 

Tgi3D Move tool allows you to move the vertices of a line or curve under the view-lock constraint,  
or on a face or along the image plane of the active view. This way you can stress or stretch curves 
as desired or to fit the underlying photograph. It has a different behavior than the SketchUp move 
tool. 

Tgi3D Move tool applies Tgi3D specific constraints to the motion of the entity begin moved:

1. If the entity has a view-lock, the tool applies the view-lock constraints in motion so that its 
appearance on the locked view does not change.

2. If  there is  no view-lock  constraint  on the entity begin  moved and the 'Shift'  key is  not 
pressed then it is moved freely on a plane parallel to the current view and passes through 
the entity. This motion helps alignment over an image.

3. The 'Shift' modifier restrains the motion to the face-plane close to the entity being moved 
(see Section 6.11. for an example).

4. The  'Ctrl' modifier causes the entities being moved to be converted to a Bézier curve if 
possible before motion (see Section 6.1. ).

When you move the cursor over to a vertex in Tgi3D move tool, the vertex changes color and 
shape to show its lock and fix status (see Section  5.and Table 1).



 16.  Construction Point Tool

Menu: Tools > Construction Point

Toolbar icon: 

Construction points are SketchUp entities that provide guidance in drawing. Tgi3D Move tool and 
the locking mechanism applies to these points as well. The calibration points used in Tgi3D® CT 
are exported as construction points to help drawing already aligned boundaries using SketchUp 
tools. As there is no tool to directly create construction points in SketchUp, Tgi3D® SU has a simple 
tool for creating construction points.

To draw a construction point

1. Choose Tgi3D Construction Point tool from the tools menu or the toolbar.

2. Left click on the desired position. The depth will be assigned by SketchUp using coincident 
geometry (i.e. if there is a plane/face the point will be placed on the face, if it is close to an 
edge the point will be on that edge etc). 
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 17. Cross Section Tool

Menu: Tools > Cross Section

Toolbar icon:

Cross  section  editing  tool  enables  you  to  efficiently  edit  cross  sections  of  extrusions  (see 
Section  9. for  details).  Inside  this  tool  when  you  move  the  cursor  on  a  cross  section  of  an 
extrusion,  the cross section that  will  be affected will  be highlighted in magenta.  When the left 
mouse button is clicked down and dragged the cross section is transformed in a way determined 
by the key modifier.

There are three types of  transformations applied on the cross section,  depending on the key 
modifier

1. No Modifier:  The cross section is expanded or shrinked. The expand and shrink method 
can be chosen from Tgi3D Settings dialog (see Section  24.) as scale or offset (default is 
scale).

2. Shift Modifier: Translate the selected cross section longitudinally.

3. Ctrl Modifier: Translate the selected cross section transversely. (Windows) 

alt/option Modifier: Translate the selected cross section transversely. (Mac)

Double  clicking with left  mouse button on an edge highlighted in  green,  creates a  new cross 
section  on the extrusion passing though the point specified by the mouse cursor. 



 18.  Set World Coordinates Tool

Menu: Tools > Set World Coordinates

Toolbar icon: 

You can  use  Set  World  Coordinates tool  to  change  the  world  coordinate  system so that  the 
cameras and the reconstructed objects lie over the ground plane and cast shadows correctly  (see 
Section  4.). The tool works similar to the Axes tool of SkecthUp.
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 19. Warper Tool
Menu: Tools > Warper

Toolbar icon: 

Warper is a Tgi3D tool that help modelers deform the selected surfaces including the ones inside 
the selected groups and components. See Section  8. for details.



 20.  Channel Extrude Tool 

Menu: Tools > Channel Extrude

Toolbar icon: 

Channel Extrude tool extrudes selected edges along a preselected connected path of edges. The 
extrusion is constrained so that the alignment of the extruded edges with respect to the ground 
plane does not change. See Section  13.2. for details.
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 21. Image-Based Surface Modeler Tool (PhotoScan Only) 

Menu: Tools > Image-Based Surface Modeler

Toolbar icon: 

Image based surface modeler is a Tgi3D tool that help modelers create free form surfaces that 
match the images  on photomatch-pages.  (see Section   9. for  details  of  image-based  surface 
modeling). The tool pops up Image-Based Surface Modeler toolbar shown below:

The  Image-Based Surface Modeler toolbar contains the following commands:

Toolbar Icon Menu command

Tools > Initial Estimate

Tools > Single-Segment Surface

Tools > Multi-Segment Surface

Tools > Refine Estimate

Tools > Upsample Mesh

Tools > Flip if necessary

Tools > Image-Based Surface Modeler Help



 22.  Tgi3D® SU Menu Items
The Tgi3D®  SU menu items appear within the related SketchUp menus and the Tgi3D® SU tools 
appear as a group on the Tgi3D toolbar (see Figure 1).

 22.1. Select all Curves
Navigation: Edit > Select all Curves

This menu item selects all the Bézier curves created by Tgi3D® SU in the model. It is useful for 
viewing the curves on a surface.

 22.2. Update Tgi3D page axes
Navigation: Tools > Update Tgi3D page axes

This menu item sets the world coordinate axes (The red, green, blue axes of SketchUp) of the 
photo match pages to the current one.  

 22.3. Purge Photos and Locks
Navigation: Edit > Purge Photos and Locks

This menu item removes the photographs and locks from the current project to reduce the file size 
after the 3D model has been built to desired specifications.

 22.4. Tgi3D Settings
Navigation: Edit > Tgi3D Settings

This menu item launches the Tgi3D Settings dialog box (see Section  24.)

 22.5. Tgi3D Select
 Navigation: Tools > Tgi3D Select

This menu item activates the  Tgi3D Select tool.  The  Tgi3D Select tool icon on the toolbar will 
appear as pressed when this menu item is clicked.

 22.6. Tgi3D Move
Navigation: Tools > Tgi3D Move

This menu item activates the Tgi3D Move tool. The Tgi3D Move tool icon on the toolbar will appear 
as pressed when this menu item is clicked.

 22.7. Construction point
Navigation: Tools > Construction point

This menu item activates the Tgi3D Construction point Tool. The Tgi3D Construction point tool icon 
on the toolbar will appear as pressed when this menu item is clicked.

 22.8. Cross Section
Navigation: Tools > Cross Section

This menu item activates the Tgi3D Cross Section tool. The Tgi3D Cross Section tool icon on the 
toolbar will appear as pressed when this menu item is clicked.
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 22.9.  Set World  Coordinates
Navigation: Tools > Set World Coordinates

This menu item activates the Tgi3D Set world coordinates tool. The Set world coordinates tool icon 
on the toolbar will appear as pressed when this menu item is clicked. See Section  4. for details.

 22.10. Warper
Navigation: Tools > Warper

This menu item issues Create warper or Warp commands depending on the selection. See Section 
 8. for details.

 22.11.  Image-Based Surface Modeler
Navigation: Tools > Image-Based Surface Modeler

This menu item activates the  Image-Based Surface Modeler tool (see Section   9.). The  Image-
Based Surface Modeler tool icon on the toolbar will appear as pressed when this menu item is 
clicked.

 22.12. Initial Estimate
Navigation: Tools > Initial Estimate

This menu item issues the  Initial Estimate command of  Image-Based Surface Modeler tool (see 
Section   9.). The  Image-Based Surface Modeler tool icon on the toolbar will appear as pressed 
when this menu item is clicked.

 22.13.  Single-Segment Surface
Navigation: Tools > Single-Segment Surface

This menu item issues the  Single-Segment Surface command of  Image-Based Surface Modeler 
tool (see Section   9.). The Image-Based Surface Modeler tool icon on the toolbar will appear as 
pressed when this menu item is clicked.

 22.14.  Multi-Segment Surface
Navigation: Tools > Multi-Segment Surface

This menu item issues the Multi-Segment Surface command of Image-Based Surface Modeler tool 
(see Section   9.).  The  Image-Based  Surface  Modeler tool  icon  on the toolbar  will  appear  as 
pressed when this menu item is clicked.

 22.15.  Refine Estimate
Navigation: Tools > Refine Estimate

This menu item issues the Refine Estimate command of Image-Based Surface Modeler tool (see 
Section   9.). The  Image-Based Surface Modeler tool icon on the toolbar will appear as pressed 
when this menu item is clicked.

 22.16.  Upsample Mesh
Navigation: Tools > Upsample Mesh

This menu item issues the Upsample Mesh command of the  Image-Based Surface Modeler tool 
(see Section   9.).  The  Image-Based  Surface  Modeler tool  icon  on the toolbar  will  appear  as 
pressed when this menu item is clicked.



 22.17. Flip if necessary
Navigation: Tools > Flip if necessary

This menu item issues the Flip if necessary command of the Image-Based Surface Modeler tool 
(see Section   9.).  The Image-Based  Surface  Modeler tool  icon  on the toolbar  will  appear  as 
pressed when this menu item is clicked.

 22.18.  Image-Based Surface Modeler Help
Navigation: Tools > Image-Based Surface Modeler Help

This menu item  pops up a window that  displays detailed information about  the  Image-Based 
Surface Modeler tool (see Section  9.). The Image-Based Surface Modeler tool icon on the toolbar 
will appear as pressed when this menu item is clicked.

 22.19. Check for Tgi3D Updates
Navigation: Help > Check for Tgi3D updates

This menu item checks the Tgi3D servers to see if there is an update of the product.

 22.20. About Tgi3D 
Navigation: Help > About Tgi3D 

The About Tgi3D menu item launches the Tgi3D splash screen, which displays information about 
the version of the program, licensing and copyrights.

 22.21.  Import Tgi3D Calibration...
Navigation:  Plugins > Tgi3D > Utils >  Import Tgi3D Calibration...

This menu item imports the files exported by Tgi3D® CT prior to version 1.16. You dot not need this 
menu item if you have Tgi3D CT version 1.16 or higher.

 22.22.  Group to transport
Navigation:  Plugins > Tgi3D > Transport >  Group to transport

See Section 12. for more details.

 22.23.  Ungroup to transport
Navigation:  Plugins > Tgi3D > Transport >  Ungroup from transport

See Section 12. for more details.
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 23. Context Menu Items
The following are the list of Tgi3D items that appear in the context menu when you right click on a 
selected  entity.  The  context  menu  contains  all  of  the  commands  available  to  manipulate  the 
currently selected entity.  The contents of the context menu changes depending on the entity that 
has been selected. 

You can also access the context menu via the entity commands sub menu (which changes its 
name depending on the entity that has been selected) under SketchUp's Edit menu.

 23.1. Lock selection
This item locks all the vertices in the selection set with respect to the current view. A view-lock 
ensures that the locked vertex can be moved in other views only in such a way that its position in 
the original view does not change.  See Sections 2., 5. and 15. for  more information on view-
locking.

 23.2. Unlock selection
This item unlocks all the entities in the selection set.

 23.3. Lock curve
This item locks the Bézier curve (see sections   6. and  5.2.) highlighted by the Tgi3D move tool 
with respect to the current view. A view-lock ensures that the locked vertex can be moved in other 
views only in such a way that its position in the original view does not change. See Sections 2., 5. 
and 15. for more information on view-locking.

 23.4. Unlock curve
This item unlocks the curve highlighted by the Tgi3D move tool.

 23.5. Lock single vertex
This item locks the vertex highlighted by the Tgi3D move tool with respect to the current view. A 
view-lock ensures that the locked vertex can be moved in other views only in such a way that its  
position in the original view does not change. See Sections 2., 5. and 15. for more information on 
view-locking.

 23.6. Unlock single vertex
This item unlocks the vertex highlighted by the Tgi3D move tool.

 23.7.  Fix selection
This  item  marks  all  the  vertices  in  the  selection  set  as  fixed  so  that  the  surface  smoothing 
operation does not move these vertices. Fixed vertices are displayed as triangles under the focus 
of the Tgi3D Move Tool cursor.

 23.8. Unfix selection
This item removes the fix on all the vertices in the selection set.

 23.9.  Convert to Bézier curve
Convert the polylines (including a single line segment) in the selection to Bézier curves.

 23.10. Resample Bézier curve... 
When this item is clicked, the Bézier Curve Info pop-up dialog appears allowing you to change the 



sampling rate on selected curve(s) by entering the desired number of vertices on each curve.

Hint:  For reasonable model size and manipulation ease, use the fewest samples that meet your 
accuracy requirement.

 23.11.  Resample Paths
When this item is clicked, the singly connected paths in selection are resampled using the segment 
length .provided in the dialog box that show up (see Section  6.13. for details)

 23.12.Create mesh
This item creates a mesh from the selected boundary.  You can ensure smooth transition from 
existing meshes by marking border edges as hidden (see Section 7.1. for details).

 23.13.  Create texture...
This item creates a textured material  and maps it  on the selected faces (see Section   11. for 
details).

 23.14.  Tag faces
This item lets you tag faces to help selecting the group of faces using the Tgi3D selection tool (see 
Section  14.3. for details).

 23.15.  Untag faces
This item lets you untag the tagged faces that help selecting the group of faces using the Tgi3D 
selection tool (see Section  14.3. for details).

 23.16.  Upsample
This item is used to increase resolution of an existing mesh (see Section  7.5. for details).

 23.17. Downsample
This item is used to decrease the resolution of an existing mesh (see Section  7.6. for details).

 23.18.  Create Warper
This item lets you create a warper for the current selection. See Sections  8. and  8.1. for details

 23.19. Warp
This  item  lets  you  apply  the  transformation  of  the  warper  to  the  corresponding  objects.  See 
Sections  8. and  8.3. for details.

 23.20.  Set warper options
This item lets you set warper options if the selection is a warper group. See Sections  8. and  8.4. 
for details.
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 23.21.Set Target Terrain 
This item lets you set selected mesh as the target  of map to terrain command. See Section  13.1. 
for details.

 23.22.  Map to Terrain
This item lets you map the selection model to the target terrain. See Section  13.1.  for details.

 23.23. Safeguard texture map
This item is used for safeguarding the texture maps of selected vertices (see Section  11.5. for 
details)

 23.24.  Restore texture map
This item is used for restoring all of safeguarded texture maps  (see Section  11.5. for details)

 23.25. Collapse
This  item is  used  for  manual  downsampling  (or  mesh  reduction).  Selected  faces,  edges  and 
vertices can be collapsed to a single point with this command.

 23.26. Move vertices to camera plane
Navigation: Other Tgi3D Utilities > Move vertices to camera plane

While drawing in SketchUp the vertices or construction points can be assigned to coordinates far 
away from the scene especially at the beginning when the ground plane is the only coincident 
geometry. This item just moves the selected vertices closer to the scene by mapping them to a 
plane parallel to the camera plane and passing through the scene.

 23.27.  Fit plane
Navigation: Other Tgi3D Utilities > Fit plane

Find the best fit plane for the selected vertices and project them on that plane so that in the end all 
the selected items lie on a single plane.

 23.28. Change angular constraints
Navigation: Other Tgi3D Utilities > Change angular constraints

This menu item launches the dialog box for entering an angular constraint  (see Section 7.9. for 
details).

 23.29. Slice
Navigation: Other Tgi3D Utilities > Slice

Slice command creates the visual cone of the selected entity. The visual cone of an edge is the 
triangle made up of the two vertices of the edge and the current viewing camera location. The 
visual cone of the selection is the union of the visual cone of all the edges.

 23.30.  Fit curve to edge (J) (PhotoScan only)
Navigation: Other Tgi3D Utilities > Fit curve to edge (J)

 Action: Press and release 'J' key

The Fit Curve to Edge menu item aligns the curve over the edges on the image. The end points of 
the curve are not moved in the alignment process (see Section 6.9.).



Note: This menu item applies only to Bézier curves.

 23.31.  Fit end points to edge (K) (PhotoScan only)
Navigation: Other Tgi3D Utilities > Fit end points to edge (K)

 Action: Press and release 'K' key

The Fit End Points to Edge menu item aligns a curve over the edges on the image by moving the 
end-points of the curve only (see Sections 6.7. and 6.9.).

Note: Key 'K'  is  mapped internally  to  another  command on SketchUp 8.  In  order  to  use this 
shortcut,  you  have  to  clear  the  SketchUp  shortcut  via  “Window  >  Preferences  >  Shortcuts” 
(“SketchUp > Preferences... > Shortcuts” on Mac).  

 23.32.  Match images (N) (PhotoScan only)
Navigation: Other Tgi3D Utilities > Match images (N)

  Action: Press and release 'N' key use Shift + N for automatic long range search

If the selection is view locked to a matched photo and the current camera is on another matched 
photo than this operation perform a color distance based shape optimization so that the projection 
of selected surface patches match in color (see Section 7.8. for more information).

If  you start from a surface too far from the real one, you may have to repeatedly perform this 
operation.  If you use the Shift key modifier the surface fitting is re-initialized through a search on  a 
larger area on the images.

 23.33.  Smooth (U)
Navigation: Other Tgi3D Utilities > Smooth (U)

 Action: Press and release 'U' key. Use Shift + U for automatic smoothing

Smoothing operation moves the vertices of the mesh such that the discontinuities or sharp features 
around the soft/hidden/smoothed edges are minimized. In this type of smoothing the mesh vertices 
are not allowed to move along the surface to preserve mesh topology. See Section  7.2. for more 
information.

You can issue the command repeatedly by hitting  the 'U' key or press 'Shift+U' instead to reach to 
the steady state of the smoothing quickly. 

 23.34. Redistribute and Smooth (Y)
Navigation: Other Tgi3D Utilities > Redistribute and Smooth (Y)

 Action: Press and release 'Y' key. Use Shift + Y for automatic redistribution and smoothing

In redistribute and smooth, the mesh vertices are left completely free to get a smooth surface with 
close to uniform vertex distribution. The surface is assumed to be made up of either a stiff  or 
elastic material depending on the option selected in the Tgi3D Settings dialog shown in Figure 21. 
See Section  7.3. for more information.

You can issue the command repeatedly by hitting  the 'Y' key or press 'Shift+Y' instead to reach to 
the steady state of the redistribution quickly. 

 23.35. Plane Optimization (D) (advanced)
Navigation: Other Tgi3D Utilities > Plane Optimization (D)

 Action: Press and release 'D' key. Use Shift + D for automatic plane optimization

The purpose of plane optimization is to completely planarize an almost planar surface to be able to 
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drop smooth/soft/hidden edges inside the surface. Plane optimization operation is used especially 
when you want to create objects whose faces are all planes, e.g. cubes, cuboids, hexahedrons, 
tetrahedrons etc. Also see Section 7.9. for related information.

You can issue the command repeatedly by hitting  the 'U' key or press 'Shift+U' instead to reach to 
the steady state of the planarization quickly. 

 23.36. Remove Unnecessary Edges
Navigation: Other Tgi3D Utilities > Remove Unnecessary Edges

An edge is unnecessary if the faces on its two sides are almost coplanar. This command removes 
such edges in the selection.

 23.37. Triangulate Faces
Navigation: Other Tgi3D Utilities > Triangulate Faces

Triangulate faces command triangulates non-triangular faces in the selection. 

 23.38. Element Count
Navigation: Other Tgi3D Utilities > Element count

Report number of vertices, edges and faces in selection.

 23.39.  Group to transport
Navigation:  Other Tgi3D Utilities >  Group to transport

See Section 12. for more details.

 23.40.  Ungroup to transport
Navigation:  Other Tgi3D Utilities >  Ungroup from transport

See Section 12. for more details.



 24. Tgi3D Settings Dialog Box

Menu: Tools > Tgi3D Settings

Toolbar icon:

Tgi3D Settings dialog box contains a number of options affecting the surface smoothing, mesh 
creation, image matching and cross section editing processes. There are two types of options: 
1) Model Specific Settings that only affect the current model and are saved with it, and 2) Global 
Settings that affect all the instances of the Tgi3D® SU as shown in Figure 21.

 24.1.  Model Specific Settings

 a) Surface Smoothing Optimizations Options

• Assume Bézier curves as fixed: When this option is checked, Bézier curve vertices inside 
the  selected  region  are  assumed to  be  fixed  by  default  for  the  smoothing  operations. 
Otherwise these Bézier curve vertices (unless explicitly marked as fixed) are also  moved 
during smoothing.

• Redistribute  and smooth In redistribute and smooth operation the surface is assumed to 
be made up of either one of the two types of materials.

1. Stiff material: It is difficult to bend stiff materials

2. Elastic material: Elastic material bends very easily.

 b) Mesh Operations (Create/Upsample) Options

• Curve  crease angle: Sets  the maximum crease angle  (in  degrees)  for  noncurve hard 
edges (and boundaries) where the connected edges with a crease angles less than then 
the set value are assumed to be continuing during upsample operation.

This  crease  angle  value  is  also  used  for  the  boundary  edges  during  the  smoothing 
optimizations  to  split  the  perimeter  boundary  into  connected  segments.  If  unexpected 
behaviour is observed during smoothing optimization, you can try changing this value.

• Split boundary edges: If this option is checked, very long boundary edges of the mesh to 
be created are split to smaller pieces to avoid skinny triangulations.

 c) Image Matching Options

• Surface stiffness: Sets the stiffness of the surface to be used in image matching.

 24.2. Global Settings

• Split  Selection boundary in upsample: When this options is  checked the edges and 
faces at the boundary of the selection are split  and triangulated otherwise no splitting is 
performed.

• Use SketchUp groups in mesh editing:  When this  options is checked,  the results  of 
some  mesh  editing  operations  (up-sampling  and  down-sampling)  are  placed  in  a  new 
group. If you want to merge the result with the rest of the scene, you need to explode the 
group. Using the SketchUp groups results in faster processing in mesh editing.

• Direct  context  menu access to Tgi3D commands:  When this  option  is  checked the 
Tgi3D menu items are placed directly under the context menu of SketchUp otherwise the 
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commands can be accessed through the “Tgi3D Commands” sub-menu.

• Cross section edit method:  Determines the expand / shrink method of cross sections. 
One method is the 'offsetting' as in the  Offset tool of SketchUp, the other one is scaling, 
that avoids topological changes in the cross section.

• Language:  Set  the language of the menu item names and help content for Tgi3D® SU 
plug-in.

Figure 21: The Tgi3D Settings dialog box


	1. Welcome to Tgi3D® SU Plugin Help
	2. Tgi3D® SU Overview
	2.1. View-locking
	2.2. Tools and Commands

	3. Setting up the Matched Photo Pages
	4. World Coordinates and Drawing Axes
	5. View Locking
	5.1. View locking vertices of a line
	5.2. View locking a Bézier Curve
	5.3. View locking a single vertex or construction point
	5.4. View locking vertices of a selection

	6. Editing lines, Bézier curves and Construction Points
	6.1. Converting a line to a Bézier curve
	6.2. Stretching and stressing a curve
	6.3. Exploding a Bézier curve
	6.4. Splitting a line or a curve
	6.5. Changing sampling rate on the curve
	6.6. Drawing a 3D line matching to the photographs
	6.7. Matching lines to image features automatically (PhotoScan Only)
	6.8. Drawing a 3D curve matching to the photographs
	6.9. Matching curves to image features automatically (PhotoScan Only)
	6.10. Drawing a 3D construction point matching to the photographs
	6.11. Moving lines and curves restricted to a face-plane
	6.12. Snapping a vertex to another vertex
	6.13. Re-sampling Paths
	6.14. Temporarily hiding the drawing

	7. Creating and Editing Smooth Surfaces
	7.1. Creating a surface
	7.2. Smoothing a surface
	7.3. Redistributing the Vertices of a Mesh
	7.4. Changing Surface Shape using Control Curves
	7.5. Increasing the resolution of a surface
	7.6. Decreasing the resolution of a surface
	7.7. Image-Based Surface Modeling (PhotoScan Only)
	7.8. Smart surface matching to photographs (i.e. image matching) (PhotoScan Only)
	7.9. Entering Angular Constraints
	7.10. Create Mesh Options Dialog Box
	7.11. Downsample Options Dialog Box
	7.12. Upsample Options Dialog Box

	8. Warping Objects
	8.1. Creating the Warper
	8.2. Editing the Warper
	8.3. Transforming the object
	8.4. Warper Options

	9. Image-Based Surface Modeling (PhotoScan Only)
	9.1. Initial Estimate
	9.2. Single-Segment Surface
	9.3. Multi-Segment Surface
	9.4. Refine Estimate
	9.5. Upsample Mesh
	9.6. Flip if necessary
	9.7. Image-Based Surface Modeler Help

	10. Editing Extrusions
	10.1. Types of Cross Section transformations
	10.2. Creating a cross section
	10.3. Confusions in cross section resolution

	11. Creating and Mapping Textures
	11.1. Applying texture on a selected region
	11.2. Editing the created texture
	11.3. Applying texture on the whole surface of an object
	11.4. Create Texture Options Dialog Box
	11.5. Safeguarding texture maps

	12. Transporting Model to a New Calibration (PhotoScan Only)
	13. Terrain Operations
	13.1. Terrain Mapping
	13.2. Channel Extrusion

	14. Tgi3D Select Tool
	14.1. Selecting a face and its edges
	14.2. Selecting multiple faces
	14.3. Tagging faces
	14.4. Bounded selection
	14.5. Incremental Bounded selection
	14.6. Selecting the boundaries and curves on a surface
	14.7. De-selecting faces and their edges
	14.8. Bounded deselection
	14.9. Deselecting the boundaries and curves on a surface

	15. Tgi3D Move Tool
	16. Construction Point Tool
	17. Cross Section Tool
	18. Set World Coordinates Tool
	19. Warper Tool
	20. Channel Extrude Tool
	21. Image-Based Surface Modeler Tool (PhotoScan Only)
	22. Tgi3D® SU Menu Items
	22.1. Select all Curves
	22.2. Update Tgi3D page axes
	22.3. Purge Photos and Locks
	22.4. Tgi3D Settings
	22.5. Tgi3D Select
	22.6. Tgi3D Move
	22.7. Construction point
	22.8. Cross Section
	22.9. Set World Coordinates
	22.10. Warper
	22.11. Image-Based Surface Modeler
	22.12. Initial Estimate
	22.13. Single-Segment Surface
	22.14. Multi-Segment Surface
	22.15. Refine Estimate
	22.16. Upsample Mesh
	22.17. Flip if necessary
	22.18. Image-Based Surface Modeler Help
	22.19. Check for Tgi3D Updates
	22.20. About Tgi3D
	22.21. Import Tgi3D Calibration...
	22.22. Group to transport
	22.23. Ungroup to transport

	23. Context Menu Items
	23.1. Lock selection
	23.2. Unlock selection
	23.3. Lock curve
	23.4. Unlock curve
	23.5. Lock single vertex
	23.6. Unlock single vertex
	23.7. Fix selection
	23.8. Unfix selection
	23.9. Convert to Bézier curve
	23.10. Resample Bézier curve...
	23.11. Resample Paths
	23.12. Create mesh
	23.13. Create texture...
	23.14. Tag faces
	23.15. Untag faces
	23.16. Upsample
	23.17. Downsample
	23.18. Create Warper
	23.19. Warp
	23.20. Set warper options
	23.21. Set Target Terrain
	23.22. Map to Terrain
	23.23. Safeguard texture map
	23.24. Restore texture map
	23.25. Collapse
	23.26. Move vertices to camera plane
	23.27. Fit plane
	23.28. Change angular constraints
	23.29. Slice
	23.30. Fit curve to edge (J) (PhotoScan only)
	23.31. Fit end points to edge (K) (PhotoScan only)
	23.32. Match images (N) (PhotoScan only)
	23.33. Smooth (U)
	23.34. Redistribute and Smooth (Y)
	23.35. Plane Optimization (D) (advanced)
	23.36. Remove Unnecessary Edges
	23.37. Triangulate Faces
	23.38. Element Count
	23.39. Group to transport
	23.40. Ungroup to transport

	24. Tgi3D Settings Dialog Box
	24.1. Model Specific Settings
	a) Surface Smoothing Optimizations Options
	b) Mesh Operations (Create/Upsample) Options
	c) Image Matching Options

	24.2. Global Settings


