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 1.  Introduction
Tgi3D® CT (Tgi3D® SU PhotoScan Calibration Tool) calibrates cameras from photographs. The user marks 
matching points in multiple photographs, then the program computes camera parameters and 3D location of 
the given points. You can export the calibration to other tools or you can perform distance measurements on 
the model. 

The following section explains a typical  workflow in a camera calibration project,  then Sections 3. to 7. 
provides brief information on user interface related issues on each of the processing steps in the workflow. 
Finally Section 8. provides useful guidelines on picture taking, point matching and many other issues to 
obtain accurate camera calibration results.

Note for Mac OS X Users: Effective usage of the Tgi3D SU PhotoScan Calibration Tool requires a 3-button 
mouse.  If  you  do  not  have  a  3-button  mouse,  we  recommend  you  to  use  a  program  like  
KeyRemap4MacBook (http://pqrs.org/macosx/keyremap4macbook/) to generate scroll wheel, middle-button 
and  right-button  click  events  (e.g.  command-control-cursormove,  command-click  and  control-click 
respectively).
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 2.  Workflow
In order to create 3D models of objects first you need to take the pictures of the object from different angles.  
Intuitively, your pictures should cover the whole object so that it does not have any parts that is not seen by  
any photograph and you also want to make sure that each photograph has a good overlap with at least one  
of the remaining photographs. Also note that using too many photographs with very large overlaps is only a 
burden on you and the program. See Section 8. for a more detailed description of picture taking guidelines. 
After taking the pictures and loading them in Tgi3D® CT, you need to identify matching points. Matching 
points are the projections of a single point in 3D space on the photographs. See Section 8. for extensive 
guidelines on matching points.

Note: Avoid editing/cropping/non-linear-filtering photographs in image (or photo) editors. Tgi3D® CT works 
best  with  untouched  original  data  coming  from digital  cameras.  Try  using  JPEG format  with  full  EXIF 
(Exchangeable Image File Format) info which is almost universal default format for digital cameras.

Creating 3D Models from photographs with Tgi3D® CT involves the following processing steps:

1. Create a new project or open an existing project See Section 3. for a brief information on Tgi3D® CT 
projects.

2. Load several photographs of the object taken from different angles into the project as needed. See 
Section 4. for the details of this processing step.

3. Identify matching points on different photographs. At this step you can also assign 3D locations to 
the points as additional information. The calibration tool is able to utilize this additional information to 
improve accuracy. See Section 5. for the details of this processing step.

4. In the calibration step, camera parameters are determined. These parameters will include positions 
and viewing angles of the camera(s) for each photograph (external parameters) as well as focal 
length and radial distortion (internal parameters). The calibration tool reads camera make and model 
and focal length from JPEG files. Calibration tool has a camera database comprising thousands of  
cameras. The EXIF information from the JPEG files and the database are used to form an initial  
approximation to the camera parameters. If the camera does not exist in the default database it is  
possible to add the camera to a local database, also if the photograph does not include any camera 
information you can still enter the initial parameters manually. In calibration step you can optionally 
include accuracy computation. See Section 6. for the details of this processing step.

Note: Steps 3 and 4 can be repeated after reviewing the calibration report and log files. 

5. Reconstruct  the  model.  Reconstructed  model  can  be viewed in  3D.  You can  also  measure  3D 
distances between points. If  in  the calibration step you have included accuracy computation the 
measurements will be reported along with the associated uncertainties. At this step you have to enter 
an external measurement between a pair of points for the program to scale the world correctly. You 
may also want to define a world coordinate system by providing the origin and a number of axes  
vectors.  The reconstructed model (and the calibration information if destination format is SketchUp) 
can also be exported to various formats. See Section 7. for the details of this processing step.
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 3.  Tgi3D® CT Projects
Tgi3D® CT works with a collection of files grouped into a “project” that are placed in a user selected folder on 
the computer file management system. The project is identified with a file having “.prj” extension in the same 
folder. Loss of any of the of the files, except the “outputs” sub-folder, in the project folder results in loss of 
information or even the loss of the whole project due to file integrity violation. The “outputs” folder on the  
other hand holds temporary outputs can be deleted to save space in case of porting the project to another 
location.

 3.1.  Creating a new project

To create a new project:

1. Issue a New Project command in one of the following ways:

◦ Select File > New project... from Menu bar 

◦ Click New Project button from the File toolbar. 

◦ Use keyboard shortcut Ctrl+N (command-N on Mac)

2. Select a folder (or create a new folder) to create the project using the “Browse For Folder” dialog box 
and click “OK”. 

The name of the project is assigned to be the same as the name of the selected folder. 

If you already have another project open and the project has unsaved work before this action, you will be 
prompted to save the current project, continue without saving, or cancel the operation. 

When a new project is opened, the name of the new project appears on the title bar and the project is empty 
at the beginning, i.e. there are no images listed in the project window and the drawing and viewing area is  
empty. 

Note: If you have another project in the folder that is selected as a placeholder for the new project, that  
project is opened instead of a new project.

 3.2.  Opening an existing project

To open an existing project:

1. Issue an Open Project command in one of the following ways:

◦ Select File > Open project... from Menu bar 

◦ Click Open Project button from the File toolbar. 

◦ Use keyboard shortcut Ctrl+O (command-O on Mac)

2. Browse for and select the existing project file with extension “.prj” from the “Open Project” pop-up 
dialog and click “OK”. 

If you already have another project open and the project has unsaved work before this action, you will be 
prompted to save the current project, continue without saving, or cancel the operation. 

When an existing project is opened, the name of the project appears on the title bar, the list  of images 
included in the project will be listed in the Project Window and the drawing and viewing area will show the  
images.
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 3.3.  Saving the project

To save the your work on the currently selected image click File > Save from the Menu bar.

To save a project:

1. Issue a Save All command in one of the following ways:

◦ Select File > Save All... from the Menu bar

◦ Click the Save All button on the File toolbar.
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 4.  Loading and Navigating Through Photographs
When the project is created it is empty and does not contain any images, First thing to do after creating the  
project,  is  adding photographs to  the project.  In  order  to  mark matching points,  one should  be able  to 
navigate easily between and inside the loaded photographs to access any location on any photograph at a 
desired  zoom  level.  Precision  in  marking  points  demands  high  zoom  ratios,  while  avoiding  erroneous 
matches require lower zoom ratios where whole the scene is visible. Various window layouts and zooming  
and navigation techniques including a magnifier window are available in Tgi3D® CT, to enable fast and error-
free marking of points.

 4.1.  Loading Photographs

For accuracy and completeness the photographs need to cover the object(s) of interest from various viewing 
angles so that all the parts of the object(s) are visible in the photographs. Another important requirement in  
taking pictures is each photograph to have a good overlap with at least one of the remaining photographs. 
Note that using too many photographs with very large overlaps satisfies the two requirements above; but it  
will only become a burden on you and the program; therefore you would want to minimize the number of  
photographs. For many cases of simple objects, two views are sufficient to calibrate and reconstruct but for 
better results use at least three photographs. See Section 8. for a more detailed description of picture taking 
guidelines. 

Note: Avoid editing/cropping/non-linear-filtering photographs in image (or photo) editors. Tgi3D® CT works 
best  with  untouched  original  data  coming  from digital  cameras.  Try  using  JPEG format  with  full  EXIF 
(Exchangeable Image File Format) info which is almost universal default format for digital cameras.

To load photographs into the project:

1. Issue an Add Images command in one of the following ways:

◦ Select File > Add Images... from Menu bar

◦ Click the Add Images button from the File toolbar.

◦ Use keyboard shortcut Ctrl + I (command-I on Mac)

2. Browse for and select the images you want to load into the project, then click “Open”.

 4.2.  Workspace layout and photograph navigation

The workspace layout of Tgi3D® CT has two main components, namely Project Window, and Drawing and 
viewing area as shown in Figure 1-(a) and (b). The project window contains panes displaying the images in 
the project, camera calibration results and the cameras used in the 3D reconstruction. It also contains a sub-
window called  Image Info that  provides information about the selected image together  with  the internal 
parameters of  the corresponding camera. The  Drawing and Viewing Area  displays  selected image and 
allows editing of calibration poins. The project and image info windows can be shown and hidden using the 
corresponding items in the View menu as shown in Figure 1-(b) and (c).

You can navigate through the photographs in various modes determined by the items found under the View 
and Window menu. The following are the ways to navigate between the photographs:

• The project window:  The project window, which can be shown or hidden by the  View >  Project  
Window command displays a list of all the photographs in the project and allows you to navigate by 
clicking on the photograph names in the list as shown in Figure 1-(a) and (b). 

• The selection tabs: The selection tabs above the Drawing and Viewing Area is another mechanism 
for photograph navigation as shown in Figure 1-(a). Simply click on the tab to switch to activate the 
corresponding view. 

• Window menu:  Finally, the Next,  Previous and  Last Active commands under the  Window menu 
provides universal methods to navigate through the photographs. 
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(a) (b)

(c)

Figure 1: Different layouts of the main window

 4.3.  Navigating Inside a Photograph

Various types of zooming operations and panning form the ways of navigation inside a photograph:

 a) Zooming in and out

To zoom in and out of the image:

1. Do one of the following:

◦ Select the View > Zoom In or View > Zoom Out from the menus.

◦ Click the Zoom In or Zoom Out buttons on the Zoom toolbar.
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◦ Use mouse wheel when View > Enable Mouse Wheel Zoom option is checked.

◦ Use “+” or “-” keys on the keyboard

 b)  Zooming to fit the window frame

To fit the image to the window frame:

1. Do one of the following:

◦ Select View > Fit to Screen from the menus.

◦ Click the Fit to Screen button on the Zoom toolbar.

◦ Use “.” (the dot) key on the keyboard.

 c) Zooming to selected area

To zoom to a selected rectangular area in the image: 

1. To activate the zoom box drawing option, do one of the following:

◦ Select View > Zoom Box on the menus.

◦ Click the Zoom Box button on the Zoom toolbar.

◦ Press and hold the 'Z' key on the keyboard.

2. Draw a zoom box (a rectangular area) by clicking and dragging left mouse button. 

 d) Zooming to view selected items

To zoom all the images to selected points:

1. Do one of the following:

◦ Select View > Zoom to Selections from the menus.

◦ Click the Zoom to Selections button on the Zoom toolbar.

 e) Zooming to image dimensions

To zoom to the actual dimensions of the image:

1. Do one of the following:

◦ Select View > Normal Size on the menus.

◦ Click the Normal Size button on the Zoom toolbar.

◦ Use the “0” (zero) key on the keyboard.

 f) Panning

To pan the image

1. Do one of the following:

◦ Drag the image using the middle mouse button

◦ Use the scroll bars on the right hand side and the bottom of the image view

◦ Use  mouse  wheel  for  vertical  scrolling  when  View->Enable  Mouse  Wheel  Zoom option  is 

unchecked
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 g) Magnifying

To enable the magnifier,  press and hold the 'Shift'  key on the keyboard. A magnifier window will  appear  
around the window. The default magnifier level can be set via the magnification ratio spin box on the toolbar.  
The navigation inside the magnifier is similar. You can

i. Zoom in and out using the mouse wheel,

ii. Pan by dragging the image with the middle mouse button, and

iii. Navigate over the original image by dragging the window with the right mouse button.
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 5.  Identifying Matching Points
Matching points are the projections of a single point in 3D space on the photographs. For example, the 
corner of a table can be a calibration point in 3D and its matching points are the 2D locations of the corner on 
the photographs that sees the corner as shown in Figure 2. Precision of marking the matching points affects 
the accuracy of calibration but it is impossible to localize the matching points with infinite precision. Choosing 
matching points as sharp features, and having a wide distribution over the photographs and in 3D space are 
basic guidelines to be followed in identifying matching points. See Section 8. for more extensive guidelines.

Especially in complex scenes such as buildings or smooth textured surfaces the matching point identification 
can be error prone if  a systematic approach is not followed. The most common source of error is false  
matches arising due to to periodicity or wide angle differences between the views. 

There are two common approaches to matching point identification on the images.  In the first one a new 
feature in the scene or an existing feature is chosen and its projections are found and marked on the images  
that see it. The second one serves to increase calibration accuracy and can only be used on calibrated  
cameras and  reconstructed features in the scene. The projections of reconstructed points are observed and 
marked if necessary.

 5.1.  Matching Point Identification without 3D reconstruction

Here is a simple systematic approach for matching point identification from scratch:

1. Do one of the following:

• Choose a feature in the scene such as the corner of a table or some type of a point like texture 
on a surface or a special marker inserted in the scene.

• Choose an existing point using calibration point list sub-window, which will select its matching 
points marked previously. 

2. Choose  a  moderate  zoom  level  so  that  you  can  see  a  large  enough  portion  of  the  scene  to 
differentiate the chosen feature from similar ones.

3. Visit each photograph and by enabling the calibration point placement (or pressing and holding the 
'C' key while clicking) mark the feature using the magnifier if it is visible and not already marked. The 
magnifier  helps  sub-pixel  accurate  localization  of  the  feature.  The  calibration  point  created  will  
remain selected after it is created.

4. Match the points by clicking the Match points button in the toolbar or  use the right mouse button on 
one of the selected points. Matching clears all the selections

5. Go to step 1 for another feature.

If you have a large number of photographs, do the identification and calibration incrementally. First mark and 
calibrate a subset of cameras and points, then add more points or photographs after making sure that the  
calibration of the subset is satisfactory. If you have too many photographs and pictures it may be very difficult 
to find even a single false match. 
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 5.2.  Matching Point Identification using the 3D Model

The accuracy of camera calibration increases with the number of matching points. It is usually difficult to  
mark many matching points from sratch without any guides; peridocity or the complexity of the scene can 
make it difficult to find the projections of a feature on all the images from scratch. Mostly small number of  
points are identified to obtain a roughly calibrated system, then the number of matching points are increased 
using the projections of the reconstructed points over the images. 

(a) (b)

(c) (d)

Figure 3: The states of identifying the the projections of reconstructed 
calibration points.

In this method

1. Calibrate the system and build the 3D model.

2. Use the Show point projections command on the toolbar or in the View menu. If a point in the model 
does not have a matching point on an input image then its projection is displayed with a yellow 
marker as shown in Figure 3-(a).

3. Click on the yellow marker to select all the matching points of the correspoinding 3D point on the rest  
of the images. The marker will change shape as shown in Figure 3-(b)

4. Check the existing projections to understand the corresponding feature in the scene. The feature  
shown in Figure 3 is the upper corner of a table.

5. Click on the marker again to add the point as the matching point for the feature. The point will be  
displayed with a regular selected marker as shown in Figure 3-(d).

6. Drag the point to the center of the corresponding feature as shown in Figure 3-(d) .
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7. Apply the steps 3 to 6 especially on the projections that are far away from their true locations on the  
image.

 5.3.  Calibration Point Handling

The purpose of this interface is to place matching points accurately. The basic operations of calibration point 
creation are:

 a) Inserting a point

1. Do one of the following:

◦ Select Edit > Calibration Point on the menus.

◦ Click the Calibration point button on the Edit toolbar.

◦ Press and hold the 'C' key on the keyboard.

2. Activate the magnifier by pressing shift key on the keyboard, if the zoom level is not high enough for  
the desired precision.

3. Position the cursor (focus at the desired location) and click (left) mouse button.

 b) Selecting a point

• Position the cursor over the point and click the left mouse button.

When a point is inserted it is also selected. Selected point appears highlighted in red. The names of the  
images that have selected points in them will be marked with (p+) in the Project window and on the tabs 
above the Drawing and Viewing Area.

 c) Zooming to a selected point

• Select View > Zoom to Selections menu item or click Zoom to Selections button on the Zoom toolbar. 

 d) Unselecting a point

• Press and release the 'Esc' key on the keyboard.

 e)  Moving a point

• Position the cursor  over  the point,  press and hold the left  mouse button,  move the cursor,  and 
release at the desired new position. 

 f)  Magnifying around the cursor

• Press and hold  the 'Shift'  key.  The default  magnification ratio  of  the magnifier  can be set  form 
magnify spin-box in the zoom toolbar. See Section 4.3. g) for more details on using the magnifier.

 5.4.  Projection Handling

After the 3D model is built, Show point projections command on the toolbar or in the View menu can be used 
to display their projections.. If a point in the model does not have a matching point on an input image then its  
projection is displayed with a yellow marker as shown in Figure  3-(a). It is possible to select and convert 
projections to matching points.

 a) Selecting a projection

• Click  on the point  or  use  the  point  navigator  (see Section   5.6.)  to  select  a  projection  and  its 
corresponding matching points on the rest of the images. The marker will turn into a yellow plus sign 
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inside a circle when the projection is selected as shown in Figure 3-(b)

 b) Converting a projection to a matching point

• Just click on the selected projection to convert it to a regular matching point.

 5.5.  Matching/unmatching Points

Tgi3D® CT uses collections of points on each photograph that are matched to a single corresponding 3D  
point on the object. To match points:

1. Select the points in each photograph which correspond to the same 3D point.

2. Click  the  right  mouse  button  in  a  photograph  with  a  selected  entity.  This  will  launch  the  
Match/unmatch Selected Points dialog box.

3. Click “Match” button on the Match/unmatch Selected Points dialog box.  

You can perform the match in incremental steps, that is, if you match a new entity to another entity that  
already has a group, it is equivalent to matching all the entities in that group at once.

 5.6.  Navigating Through Calibration Points

Pressing and holding 'M' key in a photograph will bring an overlayed sub-window (on the top left corner of the 
image window) displaying 3D calibration point ids (i.e. Matched Point IDs) or projections as shown in Figure 
4. These numbers are selectable with a left-mouse-click. If you select a point or match group or a projection, 
all corresponding points in the photographs in that group will be selected . 

It is also possible the track the matching information using the projection points on the photographs. The 
following keys display matching information on demand:

• Pressing and holding 'Q' key will display matched point ids of all points as shown in Figure 4

• Pressing and holding 'B' key will display the matched point id of the selected points only.

You can de-select all the points in all photographs by clicking on the “Deselect” button in the Match/unmatch 
Selected Points dialog box.

If  you have made a false point match or inaccurate point matches,  then you would want to destroy (or  
unmatch) a matching group. To unmatch a group of points, you may follow the steps below

1. Press 'Q' key and read the id of the point with false match

2. Press 'M' key and left click on that group id 

3. Right mouse click on one of the selected points

4. Click “Unmatch” button on the Match/unmatch Selected Points dialog box.

 5.7.  Assigning 3D Coordinates to a Point

If  there are no points selected on other  photographs,  right  mouse clicking on a point  brings up the 3D 
coordinate dialog box from which you can enter, change or remove 3D coordinate values. You should enter  
coordinates separated by space or ',' (comma). You can select the coordinate units from the pull-down units 
menu inside the 3D coordinate dialog box. The defaults units are millimeters.
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Figure 4: Navigating calibration points.
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 6.  Camera Calibration
The camera calibration requires at least 8 points to be matched for at least one pair of images. If the focal 
length and/or sensor size information can not be extracted from the EXIF info or the internal/external camera  
database for the photographs, then you may also edit the camera parameters of the images before starting  
calibration.

To edit camera information of a photograph:

1. Select “Photo files” tab in the project window.

2. Double clicking on the photograph name pop's up the Image Info dialog box. 

3. If  the EXIF info is present in the photograph and the camera exists in the central database you 
cannot change any of the camera related information. 

4. If EXIF info was successfully read but camera does not exist in the camera database, then you can  
enter sensor size parameters in the Camera Info dialog box. Typically you can find that information 
through the internet or from the manual of the camera.

5. If no EXIF info was found in the photograph, you can select a camera from the database and enter a 
compatible focal length or just enter focal length for a 35mm camera..If you do not set anything it is  
going to be assumed to be a 35mm camera with a default focal length set by the system.

To calibrate the cameras, use the Tools > Camera Calibration command for the Camera Calibration Settings 
dialog box to show up. There are two basic settings associated with camera calibration:

• If you want accuracy level computation to be performed, select the “Create Calibration Uncertainty 
(or Accuracy) Information' option in the dialog box. With this option being on, the measurements are 
reported with uncertainty using 95% (i.e. 2 ) confidence interval. Checking this option will slow down 
the camera calibration process slightly.

• By default  the calibration computations use the previous calibration as the starting point,  in rare  
cases,  this  may create  a  convergence problem.  You can initialize  the calibration completely  by 
selecting the “Ignore Previous Calibration” option in the dialog.

After  setting  the  desired  options,  click  “Run”  button  to  calibrate  the  cameras.  When the  calibration  is 
completed a report containing internal camera parameters,  projection errors and estimated user error is 
generated, you can review the report by clicking “View Report” button. The project window and the selection 
tabs will indicate the calibrated cameras with a (C) symbol following the name of the photograph.

Tgi3D® CT calibration tool is able to perform calibration even with gross user errors, if there are sufficient 
correctly entered points. When calibration process is completed, point calibration errors are reported as a list  
inside the Project Window under the “Point errors” tab (where largest errors reported first). You can navigate 
through and fix calibration points by clicking on the errors in the report list. High error rates indicate bad  
calibration mostly due to inaccurate point matches or false matches.

By default calibration tool generates the most accurate calibration, for normal cases. In case of failures, you 
can also choose to follow the advanced camera calibration process, to get a finer control of the calibration  
engine. The best way to cope with calibration failures is to provide more and more calibration points visible 
on as many cameras as possible. Advanced calibration is the very last resort meant for users with basic  
technical knowledge on image formation and parameter estimation process. In general, i f the correct focal 
length information on the cameras are available and there are plenty of calibration points you should not  
need to use the advanced calibration. 

Advanced calibration allows you 

1. To supply a default focal length for the cameras with unknown focal lengths

2. To decrease the complexity of the camera model by fixing the focal length and/or radial distortion to 
constant values. A camera model with fewer degrees of freedom helps the system converge with 
fewer number of points.

3. Adjust the number of iterations through the 'recalibration count' field. 10 should be enough for most 
cases. If you increase this number much above 100, then the calibration will take a long time.

4. You can also save the current calibration to the local camera database. This way if the same camera  
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same  focal  length  combination  is  encountered  the  calibration  starts  from  a  much  better 
approximation.
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 7.  Reconstruction / Exporting
Once the camera calibration is complete, it is possible to reconstruct and view the calibration points. You can  
launch the 3D model viewer by doing one of these::

• Select Tools > Build 3D model 

• Click Build 3D model button from the Edit toolbar

• Use keyboard shortcut Ctrl+R (command-R on Mac)

The 3D viewer window is activated and identified by the label 'model'. The calibration points are shown in 3D 
overlaid with the photographs. If you left click on a 3D point its projections are automatically selected and 
marked as such. 

The 3D viewer lets enter an external measurement between a pair of points for the program to scale the 
world correctly and  define a world coordinate system by providing the origin and a number of axes vectors.  
Right double clicking on a points sets it as the origin of the world coordinate system. Consecutive right clicks  
on two different points pops up a context menu that

• displays  the distance measurement and allows editing it using the distance measurement dialog 
box,

• set the vector between the points parallel to an axis in the world coordinates. If the two points are the  
same it can be set as the origin of the world coordinate system.

• delete the measurement or the axis constraint or the origin associated with the point(s)

The 3D viewer can show the model from an arbitrary viewing angle. It also contains fixed views for each 
calibrated camera. By clicking on the tabs above the model window or the entries 3D model page of project 
window, you can navigate to camera views corresponding to that photograph.

It  is  also  possible  to  judge  the  quality  of  calibration  from the  reported  3D distance  uncertainties.  High  
uncertainties indicate semi-stable calibrations. Increasing the number of calibration points and/or the number  
of photographs can help increase the quality of calibration and reconstruction.

Finally, when you are satisfied with the quality of reconstruction and calibration you can export it to other  
formats by either selecting Tools > Export or using keyboard shortcut Ctrl-E (command-E on Mac), which will  
launch the Export Dialog box.  The export dialog box allows you to select an output format and the image 
resolution  level  for  exporting  the  camera  parameters,  images  and  the  reconstruction  of  points  used  in 
calibration.

Note: Currently  calibrated  camera  parameters  and  images are  exported only  for  SketchUp by creating 
“Photo Match” pages which lets the user draw easily over the images. In other formats only the reconstructed 
points are exported.
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 8.  Guidelines for Improving Accuracy
Tgi3D®  CT correctly reports the level of achieved accuracy, and the user can confidently decide on usability  
of the measurement results. Using Tgi3D®  CT and today's digital cameras, it is possible to obtain average 
modeling errors as small as 0.1 pixels and relative distance errors less than 1 part in 10000.  For most  
applications this level of accuracy is not needed. Still, if you want to get the most out of the calibration tool 
and the photographs, a few simple guidelines that you can follow are listed below.

• Accuracy  expectation: Your  relative  uncertainty  in  a  distance  measurement  will  roughly  be 
positional uncertainty (in pixels) divided by the largest number of pixels covered in a photograph by 
that distance. Therefore your distance measurement accuracy will increase by the photographs pixel 
size and decrease by blur. You will find that doubling the image size by interpolation will in general  
give you no accuracy gain. Depending on the image quality reducing image size may not reduce 
accuracy either. You should avoid fake high resolution in the photographs.

• Photo quality: You should aim the best photograph quality you can achieve without fake excess 
resolution. Higher quality photographs enable better point positioning. Try to avoid camera shake, 
defocus blur, over/under exposure.

• Framing: Try to take your photographs such that the scene of interest fills most of the frame; this 
way you can get higher positioning accuracy since you will get more pixels for the same distances.

• Same camera for all photographs:  Try to take your photographs with the same camera, at the 
same focus length and same focus depth and same aperture; this way the calibration tool has fewer  
parameters to estimate, and you can get good accuracy with fewer matching points.

• Have enough overlap in photographs:

• Visible overlap:  For a 3D point to be a useful match point it has to appear in at least 2  
photographs more, the better,  therefore you can not rotate around your object/scene too 
much, between successive shots.

• Narrow angle pairs:  You should avoid photographs from very close vantage points. You 
should rotate around the scene/object enough to get good 3D information. 

• Avoid using too many photographs.  It  creates unnecessary burden on the user  and the 
calibration tool.

• The above three concerns generally contradict each other, and you should strike a balance.  
Fortunately Tgi3D® CT faithfully reports the achieved level of accuracy. You can increase 
photographs and matching points generally to meet your accuracy requirements.

• Calibration points: Your matching points should be well distributed in 2D and 3D. Avoid squeezing 
all  you matching points to a small  section in photographs. Also your matching points should be 
distributed in the volume of interest.

• Number of matching points: The more the better. Try to put around 10 points in each photograph.

• Scale measurement choice: Calibration tool  is able to fathom relative distances only.  Hence it 
needs an absolute  distance reference,  (that  is you have to enter the distance between two 3D 
points) for scaling. You should use two good quality points (good visibility, low error) that more or 
less span your model. (that is your reference distance should not be too small compared with the 
rest of the distances.). Also note that the distances that are closer to the reference distance has  
better accuracy.

• Feature  selection: Perceived  features  may  shift  due  to  exposure  change,  blur  and  partial/full 
saturation. Radially symmetric features (like the center of a small rectangle or a circle) are immune 
to  that  kind  of  shift.  Prefer  radially  symmetric  features,  try  to  keep  the  exposure  same,  avoid 
nonlinear filtering to reduce errors introduced this way. We provide a feature pattern set of varying 
sizes. You can print them on sticky paper and use them as features with high accuracy.

• Fixing erroneous matches: After calibration is performed Tgi3D® CT reports point mismatch errors 
in descending order, You can inspect your marked points and make corrections if necessary. If there 
are enough calibration points Tgi3D® CT can work under even gross mismatch errors, (for example 
top of a building marked a bottom in another photograph). In case of a gross mismatch you will likely 
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be reported large mismatch errors. You should inspect the calibration points starting from the largest  
errors. The erroneous match does not have to be the largest error.

• Transparent materials: Avoid marking calibration points behind glass water etc. Even a very thin 
transparent  material  can  introduce  an  apparent  shift  of  several  pixels,  reducing  the  achievable 
accuracy.

• Using rough calibration: You can use a crude calibration to discover new matches. To do this you 
switch to 3D model and inspect 3D projections of calibrations in the photographs. You can select 3D 
points by left clicking them in 3D model view after which you can mark those points in additional  
photographs in which they are not already marked, and finally perform a match.
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